summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 10:48:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 10:50:50 +0200
commit044cfda5596e0a3cd99588e1ed5ace9a0823604a (patch)
treef35f73782e77c7f877f26d8002d965ba378fcb7c /dev-python/isodate
parentdev-python/idna: Enable py3.11 (diff)
downloadgentoo-044cfda5596e0a3cd99588e1ed5ace9a0823604a.tar.gz
gentoo-044cfda5596e0a3cd99588e1ed5ace9a0823604a.tar.bz2
gentoo-044cfda5596e0a3cd99588e1ed5ace9a0823604a.zip
dev-python/isodate: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/isodate')
-rw-r--r--dev-python/isodate/isodate-0.6.1-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/isodate/isodate-0.6.1-r1.ebuild b/dev-python/isodate/isodate-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..c5c33e97ca77
--- /dev/null
+++ b/dev-python/isodate/isodate-0.6.1-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO 8601 date/time/duration parser and formatter"
+HOMEPAGE="
+ https://github.com/gweis/isodate/
+ https://pypi.org/project/isodate/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest -s "${BUILD_DIR}/install$(python_get_sitedir)/isodate"
+}