summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-29 03:13:00 -0400
committerTim Harder <radhermit@gentoo.org>2017-10-29 03:17:40 -0400
commitbffa3c32f135943023b25d7b8a01fcc78b2f32c6 (patch)
treeff69a4724f2dad833aed7f4cf59c56a924a4b89c /dev-python/pyusb
parentnet-analyzer/munin: add 2.0.34 (diff)
downloadgentoo-bffa3c32f135943023b25d7b8a01fcc78b2f32c6.tar.gz
gentoo-bffa3c32f135943023b25d7b8a01fcc78b2f32c6.tar.bz2
gentoo-bffa3c32f135943023b25d7b8a01fcc78b2f32c6.zip
dev-python/pyusb: version bump to 1.0.2
Diffstat (limited to 'dev-python/pyusb')
-rw-r--r--dev-python/pyusb/Manifest1
-rw-r--r--dev-python/pyusb/pyusb-1.0.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyusb/Manifest b/dev-python/pyusb/Manifest
index 5139c585ca8f..f166b9af28d5 100644
--- a/dev-python/pyusb/Manifest
+++ b/dev-python/pyusb/Manifest
@@ -1 +1,2 @@
DIST PyUSB-1.0.0.tar.gz 52559 SHA256 5b34ffa74ac34f330bff949c94ee00ec4a9d147234db17ee2eed2a67c0275368 SHA512 a66cd9e3c95d0ee0959667866101f089d5ba5d425a930cc32fdf679f8c1fde8681aaf464efc96cbdad99fbae9f72086c4704f857c757b12e4ce2016e3451dcc0 WHIRLPOOL c93d3bb289646fc06bebadb7d2d5677d685e49756bbcd4ebf01e0eaec30620fbb3f7d925d3f11b9c8cb1d1af87fb357c27f0266c86b83a2c30aa001787f994ac
+DIST pyusb-1.0.2.tar.gz 68694 SHA256 49dfa601f28e9399df62004170cfb623197ad32d8399885b7f789775767b50c3 SHA512 6a264b796e17612004196a7a526a7c6df99feac9062f8354540221016411a78a65d413731aea2fc1206ed5ea2b84787078898b9ca3754164f1dfe2a9878b75a5 WHIRLPOOL 1edcbae8e4469088645e12343357e1847dbc9cf8e9b4e4fcd27e9a0e87d22017a432d7b8ac4fcb1e79678da3cd37d31133f253f644dc23f8befdd0aec37fced4
diff --git a/dev-python/pyusb/pyusb-1.0.2.ebuild b/dev-python/pyusb/pyusb-1.0.2.ebuild
new file mode 100644
index 000000000000..abedff611616
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="https://walac.github.io/pyusb/ https://pypi.python.org/pypi/pyusb"
+SRC_URI="https://github.com/walac/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# pypi releases don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:=
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS="README.rst docs/tutorial.rst"
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
+}