summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-08 14:31:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-08 14:35:44 +0100
commit2e864de4b086b1cb5c97af303d834f8a322cd79a (patch)
tree4f8d002df2f541e3dae41d8b0bd0526a42856550 /dev-python/rq
parentdev-python/websocket-client: Remove old (diff)
downloadgentoo-2e864de4b086b1cb5c97af303d834f8a322cd79a.tar.gz
gentoo-2e864de4b086b1cb5c97af303d834f8a322cd79a.tar.bz2
gentoo-2e864de4b086b1cb5c97af303d834f8a322cd79a.zip
dev-python/rq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.10.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index 500022809a50..3da3881c9a51 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1 @@
DIST rq-1.10.1.tar.gz 599678 BLAKE2B 0673ca0eea69c3f86e50f5609a9c4ed2c2d93d331479510365a744461a5d878e6de6a9683356562754a25760f8ba1d8a65f6d5acfe878e488a70c54dc0bb5b54 SHA512 1a12bd5db27eb3f9303b2f3465c2f22092f7eebfabfc1e6aa7f65de7ea139df3833f9bbdc7061de564b2418608641b3755993bb918efbf93b04df67ca942ea09
-DIST rq-1.10.tar.gz 598643 BLAKE2B 503c2e45d134434373eb89ce205dc1a82f16e0281c1f872046d51538b3352b0ffeeef72f64991d093f271c276c1a8a3be92fdda4d7db3e083549f69ea7a04560 SHA512 7e2de3e36309eb3c095d34c28d9cba340d0699b8b4b457491d12420bfc1370e0336dc10f4f1115e83ac0ea8884500750895417f8b5c2090105d3c9e32d1b5bec
diff --git a/dev-python/rq/rq-1.10.ebuild b/dev-python/rq/rq-1.10.ebuild
deleted file mode 100644
index c21155fc3464..000000000000
--- a/dev-python/rq/rq-1.10.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="simple, lightweight library for creating and processing background jobs"
-HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
-SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc ~ppc64 ~sparc x86"
-
-RDEPEND="
- >=dev-python/click-5.0[${PYTHON_USEDEP}]
- >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/sentry-sdk[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests --install pytest
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- "
-
- # Spawn Redis itself for testing purposes
- # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
- # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
- elog "Spawning Redis"
- elog "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
-
- # Run the actual tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}