summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 04:19:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 04:33:29 +0200
commit5a82877415774edfd7662350462cdf3a078ee59c (patch)
tree0c575e9540cb217a17e4a9bde367f715ed1192d4 /dev-python/sh
parentdev-lang/python: Remove ppc hack and backport re fix to 3.12.0_rc1_p1 (diff)
downloadgentoo-5a82877415774edfd7662350462cdf3a078ee59c.tar.gz
gentoo-5a82877415774edfd7662350462cdf3a078ee59c.tar.bz2
gentoo-5a82877415774edfd7662350462cdf3a078ee59c.zip
dev-python/sh: Bump to 2.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/Manifest1
-rw-r--r--dev-python/sh/sh-2.0.6.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 6b47f0760654..ae7f1052bef5 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1 +1,2 @@
DIST sh-2.0.4.tar.gz 345443 BLAKE2B b5b765c558ad8f7aa5197687b73b20e32397f195f401aa6313fb2b918d96446adad0c8f06485550fc70a623bc18f036b4fc037ee26f8acdb27358190bd4b573d SHA512 dc402941a3d6229f3331e32590e69745bf68d8680734f19661398559090fcb4b48ce3a28e1cdd7ba30b79b65c119f7b66ed6fe9351f12697670cf31a3ee7b270
+DIST sh-2.0.6.tar.gz 345496 BLAKE2B 2352aa1c560a95e59446473658d0a95609f594417c8840c84cf1d65590aa94c2225dcd8782e75d82e92cdbf86f21dbbe03a1818a5ef1800a39444ce2918bc90b SHA512 717dae58ebd08b3a86e0d30ba2a6f3055592844d064265280b97a1d29bd7d0422c9e5500b6eb999cc1a97c1c2af04cf8ed214670bc08cb2bc45e418f69560c1d
diff --git a/dev-python/sh/sh-2.0.6.ebuild b/dev-python/sh/sh-2.0.6.ebuild
new file mode 100644
index 000000000000..a5e1a5f3a1ae
--- /dev/null
+++ b/dev-python/sh/sh-2.0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="
+ https://github.com/amoffat/sh/
+ https://pypi.org/project/sh/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest
+
+python_test() {
+ local -x SH_TESTS_RUNNING=1
+ eunittest -p "*_test.py"
+}