summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-21 07:40:31 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-21 07:49:06 +0100
commitb021cf5751481ea679b0dd87cd2e23600e4dfdd0 (patch)
tree3f07abd9359022ea9bd62de03c2aee087cced6bd /dev-python/sh
parentdev-python/pychromecast: Use pypi.eclass (diff)
downloadgentoo-b021cf5751481ea679b0dd87cd2e23600e4dfdd0.tar.gz
gentoo-b021cf5751481ea679b0dd87cd2e23600e4dfdd0.tar.bz2
gentoo-b021cf5751481ea679b0dd87cd2e23600e4dfdd0.zip
dev-python/sh: Bump to 2.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sh')
-rw-r--r--dev-python/sh/Manifest1
-rw-r--r--dev-python/sh/sh-2.0.3.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/sh/Manifest b/dev-python/sh/Manifest
index 8148c073e766..8d9b3d0d8a3d 100644
--- a/dev-python/sh/Manifest
+++ b/dev-python/sh/Manifest
@@ -1 +1,2 @@
DIST sh-2.0.2.tar.gz 345351 BLAKE2B 7b1cd213f097b0893b96fbe7c5dd96a3716b6e8fcac5da49a091bbeb4f75ea2c9f7a23237d91e1a6df9fe2c1ba8ea778dad505981cfcc1ef1893404cdb030500 SHA512 dc02a69366d1140112ccf26093bbfd7d719671caf5dd6e093a5f7ef9de3428b44e9aa539e857ef72981a688cb4b40eb47aa2060c18e6074b614a1a5c2c430d83
+DIST sh-2.0.3.tar.gz 345365 BLAKE2B f818f84c71992fcfb653b757872da89a0007a873c639b3b0438a794bdfbd455e2ac22ef035b657b35da23e6890761ce7f161a02e3e0f847ee5209cec5fe911a4 SHA512 4d3bc20b2175b2507f0081af0b83faaf5eb97d131a24abaafb333a56e45d2cdb9167c3568bb40c6a6ea79b9836e335cb0d5bec2d036ce619eb312916d69fa72d
diff --git a/dev-python/sh/sh-2.0.3.ebuild b/dev-python/sh/sh-2.0.3.ebuild
new file mode 100644
index 000000000000..e05aec059c1e
--- /dev/null
+++ b/dev-python/sh/sh-2.0.3.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python subprocess interface"
+HOMEPAGE="
+ https://github.com/amoffat/sh/
+ https://pypi.org/project/sh/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests unittest