summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/simpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/simpy')
-rw-r--r--dev-python/simpy/Manifest3
-rw-r--r--dev-python/simpy/metadata.xml11
-rw-r--r--dev-python/simpy/simpy-2.3.1-r1.ebuild43
-rw-r--r--dev-python/simpy/simpy-3.0.3.ebuild41
-rw-r--r--dev-python/simpy/simpy-3.0.8.ebuild41
5 files changed, 139 insertions, 0 deletions
diff --git a/dev-python/simpy/Manifest b/dev-python/simpy/Manifest
new file mode 100644
index 000000000000..4e480d088e09
--- /dev/null
+++ b/dev-python/simpy/Manifest
@@ -0,0 +1,3 @@
+DIST SimPy-2.3.1.tar.gz 6296235 SHA256 7f5ab61409b4fa28d08a7ed8b903eda8195dc3220cb64eb177a7bb62be89e387 SHA512 39b003ba29df70a3b1a13917f2439b523c06a4f0491b1421023697adb52d096aadc281812ae97a0e7b9498dcaab6bf7a3cd42a26dcce5ec67265e0f95884a828 WHIRLPOOL 1eb975c15859322ea02c27ce78cdd27ffe5c5ae7e070447660010f1eaeb9ec43d987b0af07376d459a118d8b61003b36e86ac34c9d6a4faa1100f94d5b9f3d23
+DIST simpy-3.0.3.tar.gz 1695886 SHA256 f1ea029a67bcc58ae88f8e3ce90bd86533a92d791684186ba21d9a0499b54bc9 SHA512 ed494596664b104a467a916ef99e4205af93aa7c4dcb3210fc722ae81e199a5421a9f20fea999d68e5b3c029f14c951e7f0659ead7880c760b9c7b2b64dc19cf WHIRLPOOL d52b1ccbe6b1471dc4db28b9a2d1a73d3710f968a56af0f56cf67bacc477c43238fd636feba5a3f0312e99f93117e39abf77a54a90b458d8b127f240c114a87f
+DIST simpy-3.0.8.tar.gz 402664 SHA256 e127921510773f7b6189ab3596362809a37b87b7c2ae298b29ba3a6cca03e677 SHA512 c8c468ab60da1b357a1c62ca516a0cce51c6941f7b7795ee57c905cd8457f5614c5ff1f6d7586c0b9d9148e03251fd4f77b4e2c3c3d438e532e49bc4583fb08b WHIRLPOOL 736b72632cba64f419512fda90565bfe912c120f9bd9647bbe0446d926485819c760c51594e68d6d410f95fbce99ad7a27687cb607030864459cf53ed64036ba
diff --git a/dev-python/simpy/metadata.xml b/dev-python/simpy/metadata.xml
new file mode 100644
index 000000000000..20ac9d1cc7de
--- /dev/null
+++ b/dev-python/simpy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">simpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/simpy/simpy-2.3.1-r1.ebuild b/dev-python/simpy/simpy-2.3.1-r1.ebuild
new file mode 100644
index 000000000000..1e8e98eae583
--- /dev/null
+++ b/dev-python/simpy/simpy-2.3.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/simpy/SimPy}"
+
+DESCRIPTION="Simulation in Python is an object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="http://simpy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/SimPy-2.3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ ${PYTHON} -c "import SimPy; SimPy.test()" || die
+}
+
+python_install_all() {
+ DOCS=( AUTHORS.txt CHANGES.txt README.txt )
+ if use doc; then
+ pushd docs > /dev/null || die
+ PYTHONPATH=.. emake html && HTML_DOCS=( docs/html/. docs/build/doctrees/. )
+ popd > /dev/null || die
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/simpy/simpy-3.0.3.ebuild b/dev-python/simpy/simpy-3.0.3.ebuild
new file mode 100644
index 000000000000..1899aa7e85ce
--- /dev/null
+++ b/dev-python/simpy/simpy-3.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/simpy/SimPy}"
+
+DESCRIPTION="Simulation in Python is an object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="http://simpy.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -vv || die
+}
+
+python_install_all() {
+ DOCS=( AUTHORS.txt CHANGES.txt README.txt )
+ if use doc; then
+ pushd docs > /dev/null || die
+ PYTHONPATH=.. emake html && HTML_DOCS=( docs/_build/html/. docs/_build/doctrees/. )
+ popd > /dev/null || die
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/simpy/simpy-3.0.8.ebuild b/dev-python/simpy/simpy-3.0.8.ebuild
new file mode 100644
index 000000000000..1899aa7e85ce
--- /dev/null
+++ b/dev-python/simpy/simpy-3.0.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="tk"
+
+inherit distutils-r1
+
+MY_P="${P/simpy/SimPy}"
+
+DESCRIPTION="Simulation in Python is an object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="http://simpy.readthedocs.org/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -vv || die
+}
+
+python_install_all() {
+ DOCS=( AUTHORS.txt CHANGES.txt README.txt )
+ if use doc; then
+ pushd docs > /dev/null || die
+ PYTHONPATH=.. emake html && HTML_DOCS=( docs/_build/html/. docs/_build/doctrees/. )
+ popd > /dev/null || die
+ fi
+
+ distutils-r1_python_install_all
+}