summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-26 05:22:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-26 06:48:58 +0200
commit3896ded3a887db989e0b52120b9ad1bd2f8f0544 (patch)
tree12a344a1c6e1858679d864dcbe2c5c5ef79c3072 /dev-python/sphinx-tabs
parentdev-python/importlib_metadata: Bump to 4.12.0 (diff)
downloadgentoo-3896ded3a887db989e0b52120b9ad1bd2f8f0544.tar.gz
gentoo-3896ded3a887db989e0b52120b9ad1bd2f8f0544.tar.bz2
gentoo-3896ded3a887db989e0b52120b9ad1bd2f8f0544.zip
dev-python/sphinx-tabs: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-tabs')
-rw-r--r--dev-python/sphinx-tabs/Manifest1
-rw-r--r--dev-python/sphinx-tabs/sphinx-tabs-3.4.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/sphinx-tabs/Manifest b/dev-python/sphinx-tabs/Manifest
index 15aa9ccb183e..901b56c74d3c 100644
--- a/dev-python/sphinx-tabs/Manifest
+++ b/dev-python/sphinx-tabs/Manifest
@@ -1 +1,2 @@
DIST sphinx-tabs-3.3.1.tar.gz 523932 BLAKE2B 8b941eb549ea8a10fcd329e880b8fa15742ba7903f4f9d6422335cf889c344a1fec8f16798c286b0c0f7561c128ea297153c31d0445b867e5e23f7960698d31a SHA512 d93ba1149a20711b52f8a76f22d212fdbb97349561f3e13b53873cdb4dba8f18f645e2d73ef378c2dde3d1c0c585c1402d73f4102da0e973be0c90a5912e7036
+DIST sphinx-tabs-3.4.0.tar.gz 524212 BLAKE2B 18688d10d37e5794340ccfc5d798a31bf80374ed74e64dcb54ae53dc557d7538de39b4e29002d16735cab5ed4618189af54da2682dce195c503af442f554fef7 SHA512 2833586c7040e454cac65963a3dfb22ac7e09b0a4cd5cba9ea449d798a5d7120ce3d19ac0a9d638a9389d52773bd98ab4bde33d06924170757036ff3218f6d55
diff --git a/dev-python/sphinx-tabs/sphinx-tabs-3.4.0.ebuild b/dev-python/sphinx-tabs/sphinx-tabs-3.4.0.ebuild
new file mode 100644
index 000000000000..b39c1a69269f
--- /dev/null
+++ b/dev-python/sphinx-tabs/sphinx-tabs-3.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tabbed views for Sphinx"
+HOMEPAGE="
+ https://github.com/executablebooks/sphinx-tabs/
+ https://pypi.org/project/sphinx-tabs/
+"
+SRC_URI="https://github.com/executablebooks/sphinx-tabs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # Unpackaged rinohtype
+ tests/test_build.py::test_rinohtype_pdf
+)
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # annoying, incorrect version limitations
+ sed -i -e '/install_requires/d' setup.py || die
+}