summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-29 14:07:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-03-29 14:07:43 +0200
commitedf68f8b175ccfefa6d89c59ffa2e9995561b38a (patch)
treef5f9f8fcd5f7d2b9e0286348d2785a2b467af3e6 /dev-python/xlrd
parentdev-python/xdis: Remove redundant versions (diff)
downloadgentoo-edf68f8b175ccfefa6d89c59ffa2e9995561b38a.tar.gz
gentoo-edf68f8b175ccfefa6d89c59ffa2e9995561b38a.tar.bz2
gentoo-edf68f8b175ccfefa6d89c59ffa2e9995561b38a.zip
dev-python/xlrd: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xlrd')
-rw-r--r--dev-python/xlrd/Manifest1
-rw-r--r--dev-python/xlrd/files/xlrd-0.9.3-column.patch59
-rw-r--r--dev-python/xlrd/xlrd-0.9.4.ebuild32
3 files changed, 0 insertions, 92 deletions
diff --git a/dev-python/xlrd/Manifest b/dev-python/xlrd/Manifest
index c6f45b6489db..2771a9e0040a 100644
--- a/dev-python/xlrd/Manifest
+++ b/dev-python/xlrd/Manifest
@@ -1,2 +1 @@
-DIST xlrd-0.9.4.tar.gz 322945 BLAKE2B cdeac4ab7c68e14d564fdd6f1da35e09a6c3a070af1111bb33e7533bdc534e05ddcb59384a72cdcbad452b26e35529431f50c2511e68422aa53f7133cfcf6141 SHA512 61d21a6b0bf5a72f75b98f6a62245fd2d0d8b091b56f31cd39e83ff0d68edba5370f81b50020f6ac52d08b0b49c0920bf44661d8501ecbde5baee7d991037a6d
DIST xlrd-1.2.0.tar.gz 554079 BLAKE2B 57c956139a3e2239c9caeae66b36e384458f1f2060422575dcb63fb09b7f9050f669154d1479303640cc45fb5716e027d3b5d07282b08bd866c4e5366861ecef SHA512 eea14845701b86a2679f140c9730e8ee2722b4f859cdd870f86bf54df522d54fc3c78dc4354aeb958c72596a6349995e9d79935efc734de096f6e007945fc1b3
diff --git a/dev-python/xlrd/files/xlrd-0.9.3-column.patch b/dev-python/xlrd/files/xlrd-0.9.3-column.patch
deleted file mode 100644
index 0a9c2749d87c..000000000000
--- a/dev-python/xlrd/files/xlrd-0.9.3-column.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From 6c2c1057d2780c079218fe988d1d5243eefec159 Mon Sep 17 00:00:00 2001
-From: Konstantin Lopuhin <kostia.lopuhin@gmail.com>
-Date: Wed, 18 Jun 2014 12:43:04 +0400
-Subject: [PATCH] fix parsing of bad dimensions
-
----
- xlrd/xlsx.py | 24 ++++++++++++++++++------
- 1 file changed, 18 insertions(+), 6 deletions(-)
-
-diff --git a/xlrd/xlsx.py b/xlrd/xlsx.py
-index 53fbb89..763df0c 100644
---- a/xlrd/xlsx.py
-+++ b/xlrd/xlsx.py
-@@ -73,7 +73,8 @@ def augment_keys(adict, uri):
- _UPPERCASE_1_REL_INDEX[_x] = 0
- del _x
-
--def cell_name_to_rowx_colx(cell_name, letter_value=_UPPERCASE_1_REL_INDEX):
-+def cell_name_to_rowx_colx(cell_name, letter_value=_UPPERCASE_1_REL_INDEX,
-+ allow_no_col=False):
- # Extract column index from cell name
- # A<row number> => 0, Z =>25, AA => 26, XFD => 16383
- colx = 0
-@@ -85,9 +86,18 @@ def cell_name_to_rowx_colx(cell_name, letter_value=_UPPERCASE_1_REL_INDEX):
- if lv:
- colx = colx * 26 + lv
- else: # start of row number; can't be '0'
-- colx = colx - 1
-- assert 0 <= colx < X12_MAX_COLS
-- break
-+ if charx == 0:
-+ # there was no col marker
-+ if allow_no_col:
-+ colx = None
-+ break
-+ else:
-+ raise Exception(
-+ 'Missing col in cell name %r', cell_name)
-+ else:
-+ colx = colx - 1
-+ assert 0 <= colx < X12_MAX_COLS
-+ break
- except KeyError:
- raise Exception('Unexpected character %r in cell name %r' % (c, cell_name))
- rowx = int(cell_name[charx:]) - 1
-@@ -562,9 +572,11 @@ def do_dimension(self, elem):
- if ref:
- # print >> self.logfile, "dimension: ref=%r" % ref
- last_cell_ref = ref.split(':')[-1] # example: "Z99"
-- rowx, colx = cell_name_to_rowx_colx(last_cell_ref)
-+ rowx, colx = cell_name_to_rowx_colx(
-+ last_cell_ref, allow_no_col=True)
- self.sheet._dimnrows = rowx + 1
-- self.sheet._dimncols = colx + 1
-+ if colx is not None:
-+ self.sheet._dimncols = colx + 1
-
- def do_merge_cell(self, elem):
- # The ref attribute should be a cell range like "B1:D5".
diff --git a/dev-python/xlrd/xlrd-0.9.4.ebuild b/dev-python/xlrd/xlrd-0.9.4.ebuild
deleted file mode 100644
index ec0657e68011..000000000000
--- a/dev-python/xlrd/xlrd-0.9.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for developers to extract data from Microsoft Excel (tm) spreadsheet files"
-HOMEPAGE="
- http://www.python-excel.org/
- https://github.com/python-excel/xlrd/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~ppc-aix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-PATCHES=( "${FILESDIR}"/${PN}-0.9.3-column.patch )
-
-python_prepare_all() {
- # Remove this if examples get reintroduced
- sed -i -e "s/test_names_demo/_&/" tests/test_open_workbook.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover || die "Test failed with ${EPYTHON}"
-}