summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-11-02 17:03:32 -0700
committerZac Medico <zmedico@gentoo.org>2022-11-02 17:03:57 -0700
commit013697a32a78c815b2e69a9ff54a3000244373f4 (patch)
tree22e814f6de19f4aee422a79da022b92ca07c5280 /dev-python/yamlpath
parentapp-admin/salt: add 3005.1 (diff)
downloadgentoo-013697a32a78c815b2e69a9ff54a3000244373f4.tar.gz
gentoo-013697a32a78c815b2e69a9ff54a3000244373f4.tar.bz2
gentoo-013697a32a78c815b2e69a9ff54a3000244373f4.zip
dev-python/yamlpath: add 3.6.8
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/yamlpath')
-rw-r--r--dev-python/yamlpath/Manifest1
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.8.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
index a562dc54191e..8a6d97835994 100644
--- a/dev-python/yamlpath/Manifest
+++ b/dev-python/yamlpath/Manifest
@@ -1 +1,2 @@
DIST yamlpath-3.6.7.gh.tar.gz 219770 BLAKE2B 779b94f6aff7e6430c89508145d85d2b7b5ddb4bc1070fd68d402e27b7bf596c7e68f1bfb8683791ea2572ef6d01fe5f2de4fd646be32b8ab266747371f61f36 SHA512 7313d3eaa9268d4c2acb1bc87052068498840943be503fa160833c03f372e5c6d7604572d277b70c551784fd8c9507e084f12dd651b5c4f600f69e8ee7cefb62
+DIST yamlpath-3.6.8.gh.tar.gz 220132 BLAKE2B dc2b3c54d6e09e1d273643fa52f7079c2734eda2145a9e31cda3c5f6ff20d5e423fae7228297849a78fc7539f0865fabbb4640c9520e280e58b28dab52eee89f SHA512 6e5e43e6a25cfaf4bd7618b3e84baf6ca1cf33bd2c0f6c5ce3f58c5f22e64728610f1bb462901f8b6bd8fe2ca3b5265624e72cc8958ffdd0c612dcccfef8bc7a
diff --git a/dev-python/yamlpath/yamlpath-3.6.8.ebuild b/dev-python/yamlpath/yamlpath-3.6.8.ebuild
new file mode 100644
index 000000000000..e236b9aeee0e
--- /dev/null
+++ b/dev-python/yamlpath/yamlpath-3.6.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
+HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
+SRC_URI="
+ https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-ruby/hiera-eyaml
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ sed -e '/ruamel\.yaml/d' \
+ -e '/pytest-cov/d' \
+ -e "/find_packages/s/()/(exclude=\['tests'\])/" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install and optimize yamlpath/patches/aliasstyle.py
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ insinto "${sitedir}/yamlpath"
+ doins -r "${S}/yamlpath/patches"
+ python_optimize "${D}${sitedir}"
+}