summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-08 07:29:26 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:46:18 +0100
commit2f1eb83676880c6252f33a5982689328c7b850fe (patch)
tree27de8e75546a43d32107aaf8e389bcacfe4e162e /dev-python
parentdev-embedded/platformio: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-2f1eb83676880c6252f33a5982689328c7b850fe.tar.gz
gentoo-2f1eb83676880c6252f33a5982689328c7b850fe.tar.bz2
gentoo-2f1eb83676880c6252f33a5982689328c7b850fe.zip
dev-python/root_numpy: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/root_numpy/root_numpy-4.7.3-r1.ebuild (renamed from dev-python/root_numpy/root_numpy-4.7.3.ebuild)11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/root_numpy/root_numpy-4.7.3.ebuild b/dev-python/root_numpy/root_numpy-4.7.3-r1.ebuild
index d76b31455628..c5305f468915 100644
--- a/dev-python/root_numpy/root_numpy-4.7.3.ebuild
+++ b/dev-python/root_numpy/root_numpy-4.7.3-r1.ebuild
@@ -19,11 +19,16 @@ IUSE="examples test"
RESTRICT="!test? ( test )"
RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- sci-physics/root:=[python,${PYTHON_USEDEP}]"
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ ')
+ sci-physics/root:=[python,${PYTHON_SINGLE_USEDEP}]"
DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/nose[${PYTHON_MULTI_USEDEP}] )
+ ')"
python_test() {
cd "${BUILD_DIR}" || die