summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-20 23:29:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-21 00:59:56 +0200
commit6f4144fd5147726b242b24daddab66fd72c9146d (patch)
tree500459b76717e7093ce3541a70f6178ef9098efe /dev-python
parentdev-python/patsy: Disable broken USE=doc (requires py2) (diff)
downloadgentoo-6f4144fd5147726b242b24daddab66fd72c9146d.tar.gz
gentoo-6f4144fd5147726b242b24daddab66fd72c9146d.tar.bz2
gentoo-6f4144fd5147726b242b24daddab66fd72c9146d.zip
dev-python/patsy: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/patsy/files/patsy-0.5.1-py310.patch39
-rw-r--r--dev-python/patsy/patsy-0.5.1.ebuild6
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-python/patsy/files/patsy-0.5.1-py310.patch b/dev-python/patsy/files/patsy-0.5.1-py310.patch
new file mode 100644
index 000000000000..04a712e7e426
--- /dev/null
+++ b/dev-python/patsy/files/patsy-0.5.1-py310.patch
@@ -0,0 +1,39 @@
+From 6328c7652e4d7fda9872a555d31658e54b7b0e6e Mon Sep 17 00:00:00 2001
+From: thequackdaddy <pquack@gmail.com>
+Date: Sun, 28 Oct 2018 19:38:08 -0500
+Subject: [PATCH] MAINT: A few python 3.7 fixes
+
+---
+ patsy/constraint.py | 5 ++++-
+ tools/check-API-refs.py | 2 +-
+ 3 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/patsy/constraint.py b/patsy/constraint.py
+index ca9f6e2..d710a94 100644
+--- a/patsy/constraint.py
++++ b/patsy/constraint.py
+@@ -10,7 +10,10 @@
+ __all__ = ["LinearConstraint"]
+
+ import re
+-from collections import Mapping
++try:
++ from collections.abc import Mapping
++except ImportError:
++ from collections import Mapping
+ import six
+ import numpy as np
+ from patsy import PatsyError
+diff --git a/tools/check-API-refs.py b/tools/check-API-refs.py
+index 8e9e8a1..9349028 100644
+--- a/tools/check-API-refs.py
++++ b/tools/check-API-refs.py
+@@ -9,7 +9,7 @@
+ root = dirname(dirname(abspath(__file__)))
+ patsy_ref = root + "/doc/API-reference.rst"
+
+-doc_re = re.compile("^\.\. (.*):: ([^\(]*)")
++doc_re = re.compile("^\\.\\. (.*):: ([^\\(]*)")
+ def _documented(rst_path):
+ documented = set()
+ for line in open(rst_path):
diff --git a/dev-python/patsy/patsy-0.5.1.ebuild b/dev-python/patsy/patsy-0.5.1.ebuild
index 39d9848be72e..78b6a5d4cd69 100644
--- a/dev-python/patsy/patsy-0.5.1.ebuild
+++ b/dev-python/patsy/patsy-0.5.1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -21,3 +21,7 @@ RDEPEND="
"
distutils_enable_tests nose
+
+PATCHES=(
+ "${FILESDIR}"/${P}-py310.patch
+)