summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 14:34:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 14:34:18 +0200
commit1cdda7d2f95ec5e7fde0560a75b848cad9b719f3 (patch)
tree6498ea3a2f40ae8383472279f2c989cd21384646 /dev-ros/gazebo_ros
parentdev-ros/gazebo_plugins: Initial import. Ebuild by me. (diff)
downloadgentoo-1cdda7d2f95ec5e7fde0560a75b848cad9b719f3.tar.gz
gentoo-1cdda7d2f95ec5e7fde0560a75b848cad9b719f3.tar.bz2
gentoo-1cdda7d2f95ec5e7fde0560a75b848cad9b719f3.zip
dev-ros/gazebo_ros: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/gazebo_ros')
-rw-r--r--dev-ros/gazebo_ros/Manifest1
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.5.1.ebuild35
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-9999.ebuild35
-rw-r--r--dev-ros/gazebo_ros/metadata.xml5
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
new file mode 100644
index 000000000000..29a123496cce
--- /dev/null
+++ b/dev-ros/gazebo_ros/Manifest
@@ -0,0 +1 @@
+DIST gazebo_ros_pkgs-2.5.1.tar.gz 1812295 SHA256 1d78839d174790db400466b4b165a79fea50177a3fbe59291539b8bdc1876d4e SHA512 2e0faaa770abe9ff2b41d176c7a3dadaf8749f32c924ba6018b3d7dabf0fe2a1e4ffd24c840c777229a4941e7f4522bf2287288619e2c819d4fb3c10fa431c9d WHIRLPOOL 09b0c5038b21a6cfc355fed8d8d2981cb845c8d209cb89112fb6daf1694b735dd68096ca7e2f255fdc2e8ba435080df186057344c81c2ac247c28d64019dbe32
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.5.1.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.5.1.ebuild
new file mode 100644
index 000000000000..870276d41866
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/tinyxml
+ sci-electronics/gazebo
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
new file mode 100644
index 000000000000..870276d41866
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/tinyxml
+ sci-electronics/gazebo
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_ros/metadata.xml b/dev-ros/gazebo_ros/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/gazebo_ros/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>