summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-16 14:34:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-16 14:36:44 +0100
commit380759627d1e51d217db6d487e8d5d8670c1c0af (patch)
tree85b5ff9f1d2b0042554f8978d8fca1fd9e080d1c /dev-ros/gazebo_ros
parentdev-ros/gazebo_plugins: bump to 2.7.3 (diff)
downloadgentoo-380759627d1e51d217db6d487e8d5d8670c1c0af.tar.gz
gentoo-380759627d1e51d217db6d487e8d5d8670c1c0af.tar.bz2
gentoo-380759627d1e51d217db6d487e8d5d8670c1c0af.zip
dev-ros/gazebo_ros: bump to 2.7.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/gazebo_ros')
-rw-r--r--dev-ros/gazebo_ros/Manifest1
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild36
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-9999.ebuild3
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-ros/gazebo_ros/Manifest b/dev-ros/gazebo_ros/Manifest
index b9b68a833845..a0d2a406e418 100644
--- a/dev-ros/gazebo_ros/Manifest
+++ b/dev-ros/gazebo_ros/Manifest
@@ -1 +1,2 @@
DIST gazebo_ros_pkgs-2.6.2.tar.gz 1830633 BLAKE2B 8365084619d57d8427753e33d4a3128162c44b10552166c7070eaabde3f806cee9981c60b30b18b6cbe80b83e2871b0100b51329a1a6bd9747320245f21ec1a4 SHA512 f932eebbc88f4922c0275625d50ad5723446744cbf4a59138437d9bdd75a9b5232fdf8df2012460313eb2224d4287daebc3a28181ab3f1b81e67d70a8b8ed5d3
+DIST gazebo_ros_pkgs-2.7.3.tar.gz 1836260 BLAKE2B 7867bec1461769923ba36ea2e56b21d85cf1db254cd50a028af5953fe1b5373015b68785a90d242e245d12a2da2c7a8ff26db66c0c466e6a6e029fbb74340a06 SHA512 66590a248f0813ab0f2a80df234f9dd8d448c500726b62d3fc74397d3a618d6fae994c3e463bb0c4a8892cef35ba1729229c471f3d21d4b3a2091d5ad74cc33b
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild
new file mode 100644
index 000000000000..ca217b085352
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
index 168e26eb91b1..ca217b085352 100644
--- a/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
+++ b/dev-ros/gazebo_ros/gazebo_ros-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,6 +16,7 @@ SLOT="0"
IUSE=""
RDEPEND="
+ dev-ros/gazebo_dev
dev-libs/tinyxml
sci-electronics/gazebo:=
dev-libs/protobuf:=