summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 13:09:58 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 13:09:58 +0100
commit29b7b1929560c5c58ff41b887e8e4521b97dc823 (patch)
treed988aa1d25d4baa6b3cc01ad34f9a2dd541b7417 /dev-ros
parentdev-ros/hector_imu_attitude_to_tf: Bump to 0.4.0. (diff)
downloadgentoo-29b7b1929560c5c58ff41b887e8e4521b97dc823.tar.gz
gentoo-29b7b1929560c5c58ff41b887e8e4521b97dc823.tar.bz2
gentoo-29b7b1929560c5c58ff41b887e8e4521b97dc823.zip
dev-ros/hector_mapping: Bump to 0.4.0.
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/hector_mapping/Manifest1
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.4.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/Manifest b/dev-ros/hector_mapping/Manifest
index 1f7882454e47..dc0978f6c2bf 100644
--- a/dev-ros/hector_mapping/Manifest
+++ b/dev-ros/hector_mapping/Manifest
@@ -1 +1,2 @@
DIST hector_slam-0.3.5.tar.gz 66002 BLAKE2B 6e370fedf49b450cd3dec77eb7a197cc13796d787c41a72d5bdf918661728e96ff9e388ab1f2c5cf64c13ff6e94e058fc4c8ba176307b63cc51b892c0183dd54 SHA512 7f61c6b0607295b6b96fb9cadbaafc7531013a0d7cfaab19630c14ac52cde8920376a57041577d2c9945130200ce5912ba331dd1e3d0f41297a928a34a45dfa1
+DIST hector_slam-0.4.0.tar.gz 66634 BLAKE2B 7d4798d4c247268d01a51a8d796441807f9243d074ccd4584b759da91779d8a565de28f18bd0d7d59b71e2710c71b39d7fafd4de5de8c6fbd8d3ca453788998b SHA512 1951a31fa02b042ce167367d94ab8a8f7481dc1eb3f6dc1c0f248f552ae8cf312af1ba9519eeefd3b24bed9b593a60b0734a23de9214ca35c48f7cc33ab5d437
diff --git a/dev-ros/hector_mapping/hector_mapping-0.4.0.ebuild b/dev-ros/hector_mapping/hector_mapping-0.4.0.ebuild
new file mode 100644
index 000000000000..4e49dd7e8a0e
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"