summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-13 14:37:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-13 14:53:21 +0100
commita3aed5a67f9a4579786f71c9006226c2525c834e (patch)
treecf50910aee1929910ca6a3a58f1ba84d3b16705c /dev-ros
parentdev-ros/ament_cmake_export_dependencies: use python-any-r1 (diff)
downloadgentoo-a3aed5a67f9a4579786f71c9006226c2525c834e.tar.gz
gentoo-a3aed5a67f9a4579786f71c9006226c2525c834e.tar.bz2
gentoo-a3aed5a67f9a4579786f71c9006226c2525c834e.zip
dev-ros/ament_cmake_export_definitions: use python-any-r1
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-0.8.1.ebuild23
-rw-r--r--dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-9999.ebuild23
2 files changed, 16 insertions, 30 deletions
diff --git a/dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-0.8.1.ebuild b/dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-0.8.1.ebuild
index 37d318c6243f..7174878a8530 100644
--- a/dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-0.8.1.ebuild
+++ b/dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-0.8.1.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,19 +30,12 @@ else
fi
IUSE=""
-DEPEND="
- dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}
diff --git a/dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-9999.ebuild b/dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-9999.ebuild
index 37d318c6243f..7174878a8530 100644
--- a/dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-9999.ebuild
+++ b/dev-ros/ament_cmake_export_definitions/ament_cmake_export_definitions-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python{3_6,3_7} )
-inherit cmake-utils python-r1
+inherit cmake-utils python-any-r1
ROS_PN="ament_cmake"
if [ "${PV#9999}" != "${PV}" ] ; then
@@ -30,19 +30,12 @@ else
fi
IUSE=""
-DEPEND="
- dev-ros/ament_cmake_core[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+ $(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
${PYTHON_DEPS}
"
-RDEPEND="${DEPEND}"
-BDEPEND="${DEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-src_configure() {
- # This is a build tool that does not install python-related files
- # ... but we need to propagate the deps and use python3 to build it.
- local pyimpl="${PYTHON_COMPAT[0]}"
- python_export "${pyimpl}" EPYTHON PYTHON
- python_wrapper_setup
- cmake-utils_src_configure
-}