summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/amq-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/amq-client')
-rw-r--r--dev-ruby/amq-client/Manifest1
-rw-r--r--dev-ruby/amq-client/amq-client-1.0.4.ebuild36
-rw-r--r--dev-ruby/amq-client/metadata.xml8
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/amq-client/Manifest b/dev-ruby/amq-client/Manifest
new file mode 100644
index 000000000000..51d67c0bfee7
--- /dev/null
+++ b/dev-ruby/amq-client/Manifest
@@ -0,0 +1 @@
+DIST amq-client-1.0.4.gem 75776 SHA256 45a1161b8501f3955d9e45547666a5c1f534517255b2dc5d3d8f4c478ee6bfdf SHA512 d0c2acb3c223496f56e75070b6ac5d68317e3cffbe554b0f80c64250de7afe6e62f59b23a2dd634af4c5e17a1927cf09fe8d586541fef9d3dbc66da7779f3467 WHIRLPOOL 329df238946e3580623bfaf510698bf2cf4576ade848d4e3697a7931ad5e798de424dd3f8fb61f3997e35aa627188715520c6eaf3831f8b4ef7a364628982749
diff --git a/dev-ruby/amq-client/amq-client-1.0.4.ebuild b/dev-ruby/amq-client/amq-client-1.0.4.ebuild
new file mode 100644
index 000000000000..8914e5d635c2
--- /dev/null
+++ b/dev-ruby/amq-client/amq-client-1.0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="A fully-featured, low-level AMQP 0.9.1 client"
+HOMEPAGE="http://github.com/ruby-amqp/amq-client"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-1.2.0 dev-ruby/eventmachine"
+
+ruby_add_bdepend "test? ( dev-ruby/evented-spec )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '7i require "evented-spec"' spec/spec_helper.rb || die
+
+ # Drop integration tests since these require a running AMQP server.
+ rm -rf spec/integration spec/regression/bad_frame_slicing_in_adapters_spec.rb spec/unit/client_spec.rb || die
+}
diff --git a/dev-ruby/amq-client/metadata.xml b/dev-ruby/amq-client/metadata.xml
new file mode 100644
index 000000000000..81f12f072740
--- /dev/null
+++ b/dev-ruby/amq-client/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">ruby-amqp/amq-client</remote-id>
+ </upstream>
+</pkgmetadata>