summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-08-14 19:05:23 +0200
committerHans de Graaff <graaff@gentoo.org>2019-08-14 19:05:48 +0200
commitf59a29ee693d3a263eb20bca280ded94dc79f6f2 (patch)
tree03bb9991141c86ebc29e02bb21976c4dee19eb60 /dev-ruby/pundit/pundit-2.1.0.ebuild
parentsci-libs/dealii: fix QA issue (diff)
downloadgentoo-f59a29ee693d3a263eb20bca280ded94dc79f6f2.tar.gz
gentoo-f59a29ee693d3a263eb20bca280ded94dc79f6f2.tar.bz2
gentoo-f59a29ee693d3a263eb20bca280ded94dc79f6f2.zip
dev-ruby/pundit: add 2.1.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/pundit/pundit-2.1.0.ebuild')
-rw-r--r--dev-ruby/pundit/pundit-2.1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/pundit/pundit-2.1.0.ebuild b/dev-ruby/pundit/pundit-2.1.0.ebuild
new file mode 100644
index 000000000000..494728cf157b
--- /dev/null
+++ b/dev-ruby/pundit/pundit-2.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Object oriented authorization for Rails applications"
+HOMEPAGE="https://github.com/elabs/pundit https://rubygems.org/gems/pundit"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "test? ( >=dev-ruby/actionpack-3.0.0
+ >=dev-ruby/activemodel-3.0.0 )"
+
+all_ruby_prepare() {
+ sed -i -e "/pry/d" spec/spec_helper.rb || die
+}