summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-12-27 13:09:13 +0100
committerHans de Graaff <graaff@gentoo.org>2023-12-27 13:26:37 +0100
commit5b91cb441cf5b6df10a2236056a676796aab71bc (patch)
tree24a0b49e17a838ff6579b14a7ebc4349c92fd7c6 /dev-ruby/ruby-prof
parentdev-ruby/ruby-shadow: enable ruby33 (diff)
downloadgentoo-5b91cb441cf5b6df10a2236056a676796aab71bc.tar.gz
gentoo-5b91cb441cf5b6df10a2236056a676796aab71bc.tar.bz2
gentoo-5b91cb441cf5b6df10a2236056a676796aab71bc.zip
dev-ruby/ruby-prof: drop 1.6.1, 1.6.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest1
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.6.1.ebuild41
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.6.3.ebuild41
3 files changed, 0 insertions, 83 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index ec0b7035d818..d720f090100a 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,2 +1 @@
-DIST ruby-prof-1.6.1.tgz 243127 BLAKE2B acceb23b137d080983e0dc8f431b8b31be05db16e8820c478cc7c33f3b578e243ecb536baacbb36e4fbd4675e99f567d3c68a70f09929b3cdd6c10f21413b59b SHA512 01e85e12e2185e092ee10953239b4253da4970162e53563f5270d1b09a6b6a4606b2d15b7c97cb70b3254e3657e6874a22a1873ee28f3c62d04d066f938434a8
DIST ruby-prof-1.6.3.tgz 247407 BLAKE2B aac1ec36ee274faba919aa04be625b7b97ef61df105266f3d1b629cef6948db0bffbe67e70782f90a059221cb11cdb0df18031c9061f84cc882029cdde84629f SHA512 3172251fbd445c73f0eec734e09021ec0e375fd2f2999ec357569c679aa98ea5e0e08a18be1236e2572a8f0c302a1157d6a0d36ef04dffc4d0767accce629118
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.6.1.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.6.1.ebuild
deleted file mode 100644
index 39c10f52a3d8..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-1.6.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_prof/extconf.rb)
-RUBY_FAKEGEM_EXTENSION_LIBDIR="lib"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
-SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # Avoid bundler
- sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
-
- sed -i -e '2igem "test-unit"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
-
- # Avoid unneeded dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
-}
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.6.3.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.6.3.ebuild
deleted file mode 100644
index 5c5244c5f54c..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-1.6.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/ruby_prof/extconf.rb)
-RUBY_FAKEGEM_EXTENSION_LIBDIR="lib"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
-SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # Avoid bundler
- sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
-
- sed -i -e '2igem "test-unit"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
-
- # Avoid unneeded dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
-}