summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-23 11:43:43 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-23 11:48:08 +0100
commit3c505a9f9e2f7b4da926b6e55e88cddd1dbafe3b (patch)
tree98b5776b4590dcb7841155626512461f4c93542c /dev-ruby/settingslogic
parentdev-ruby/prawn-table: EAPI 8 (diff)
downloadgentoo-3c505a9f9e2f7b4da926b6e55e88cddd1dbafe3b.tar.gz
gentoo-3c505a9f9e2f7b4da926b6e55e88cddd1dbafe3b.tar.bz2
gentoo-3c505a9f9e2f7b4da926b6e55e88cddd1dbafe3b.zip
dev-ruby/settingslogic: EAPI 8
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/settingslogic')
-rw-r--r--dev-ruby/settingslogic/settingslogic-2.0.9-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/settingslogic/settingslogic-2.0.9-r1.ebuild b/dev-ruby/settingslogic/settingslogic-2.0.9-r1.ebuild
new file mode 100644
index 000000000000..87a72d7dacf6
--- /dev/null
+++ b/dev-ruby/settingslogic/settingslogic-2.0.9-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple configuration / settings solution that uses an ERB enabled YAML file"
+HOMEPAGE="https://github.com/binarylogic/settingslogic"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/check_dependencies/d' Rakefile || die
+}