summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-19 07:44:15 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-19 07:46:35 +0200
commit34dedfc5436ab7d16943337a0f44239998ebf52b (patch)
tree4b6e18a6595277c61fd61abdaa1b0f0f5089cd0f /dev-ruby/term-ansicolor
parentdev-ruby/unf: add 0.2.0 (diff)
downloadgentoo-34dedfc5436ab7d16943337a0f44239998ebf52b.tar.gz
gentoo-34dedfc5436ab7d16943337a0f44239998ebf52b.tar.bz2
gentoo-34dedfc5436ab7d16943337a0f44239998ebf52b.zip
dev-ruby/term-ansicolor: add 1.11.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/term-ansicolor')
-rw-r--r--dev-ruby/term-ansicolor/Manifest1
-rw-r--r--dev-ruby/term-ansicolor/term-ansicolor-1.11.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/term-ansicolor/Manifest b/dev-ruby/term-ansicolor/Manifest
index 376ed7bda3fb..1e898a12e2d8 100644
--- a/dev-ruby/term-ansicolor/Manifest
+++ b/dev-ruby/term-ansicolor/Manifest
@@ -1,2 +1,3 @@
+DIST term-ansicolor-1.11.2.gem 47616 BLAKE2B 4481e347c23af4e03061bd92df387ad996e99e86c63ab9377c713ae3f70f12a53c3aa8a411fdcf003fabaedf3e9b39275910627ebaff19b963f49b2879c7b895 SHA512 df7384dbfd68e1efe161f2edc186306a40d8492b488bfc9436cadef09d7b961bc29983a40fca93e2e127c1b502272eb01aa65cc65ba7729a81b31b37aaafcd65
DIST term-ansicolor-1.8.0.gem 45056 BLAKE2B 89edaf5ecb56dada8027ab91009b71a6ee9a27c85bddeda26d281230e0fc15f32a2de1c3259d02560bdf9c81a2ed92a920521eec17670eaa0b8db1264ff7311c SHA512 4a13f369c03d3660f48f28068f311d5eb806e2e4724da6a3ee38eb0ed3c195a1ce8ea24215dfe80af5aab8df1f6a86fdd89d54c62ee2fb9b7e782f9e5ed3013f
DIST term-ansicolor-1.9.0.gem 46592 BLAKE2B 8e9f4f4f09f57b7eef9b824a1327c4ece8be365b1eeb17f9f29437bd883a96f7339912d9d5b52546d262a49bf2f42520e451cdb0a76c08c27bc2b9bcffeed492 SHA512 a6d9bfd11b620c6bb3de204929af58b2b007359975c64b7f9485b4574e1ace68f7ac389f50a6239050735eed8ec894fa8d8d56821f7614c19ece9053d4c781cd
diff --git a/dev-ruby/term-ansicolor/term-ansicolor-1.11.2.ebuild b/dev-ruby/term-ansicolor/term-ansicolor-1.11.2.ebuild
new file mode 100644
index 000000000000..120f29602e16
--- /dev/null
+++ b/dev-ruby/term-ansicolor/term-ansicolor-1.11.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_GEMSPEC="term-ansicolor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Small Ruby library that colors strings using ANSI escape sequences"
+HOMEPAGE="https://github.com/flori/term-ansicolor"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_rdepend ">=dev-ruby/tins-1.0"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:tests -e 'Dir["tests/*_test.rb"].each{|f| require f}' || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}