summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/schoca
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/schoca')
-rw-r--r--dev-scheme/schoca/Manifest1
-rw-r--r--dev-scheme/schoca/metadata.xml14
-rw-r--r--dev-scheme/schoca/schoca-0.3.0.ebuild47
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-scheme/schoca/Manifest b/dev-scheme/schoca/Manifest
new file mode 100644
index 000000000000..e2f138d126e9
--- /dev/null
+++ b/dev-scheme/schoca/Manifest
@@ -0,0 +1 @@
+DIST schoca-0.3.0.tar.bz2 49738 SHA256 5527a8bf07faa7e715626612735a044bf970480637d98eea612bf61bb7042511
diff --git a/dev-scheme/schoca/metadata.xml b/dev-scheme/schoca/metadata.xml
new file mode 100644
index 000000000000..44caaf8cc89a
--- /dev/null
+++ b/dev-scheme/schoca/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>scheme</herd>
+ <herd>ml</herd>
+ <longdescription lang="en">
+ Schoca is an implementation of the Scheme language. The primary
+ purpose of Schoca is the use as an embedded extension language
+ in OCaml applications (e.g. the ibgsclient).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">chesslib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-scheme/schoca/schoca-0.3.0.ebuild b/dev-scheme/schoca/schoca-0.3.0.ebuild
new file mode 100644
index 000000000000..2aa501a645c4
--- /dev/null
+++ b/dev-scheme/schoca/schoca-0.3.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Schoca is a Scheme implementation in OCaml"
+HOMEPAGE="http://sourceforge.net/projects/chesslib/"
+SRC_URI="mirror://sourceforge/chesslib/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="dev-ml/findlib
+ dev-lang/ocaml[ocamlopt?]
+ || ( dev-ml/camlp4[ocamlopt?] <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+
+RESTRICT="installsources"
+
+src_configure() {
+ sed "s:\$(CFLAGS):\$(CCFLAGS):g" -i OCaml.mk || die "sed failed"
+ sed "s:CCFLAGS= -ccopt -O2:CCFLAGS= -ccopt \"${CFLAGS}\":" -i OCaml.mk || die "sed failed"
+ sed -i -e "s:\$(LDFLAGS):-cclib \"${LDFLAGS}\":" OCaml.mk || die "sed failed"
+ sed -i -e "s:DESTDURFLAG:DESTDIRFLAG:" OCaml.mk || die "sed failed"
+ if ! use ocamlopt; then
+ sed -i -e 's/ \$(PROGRAM)\.opt/ \$(PROGRAM)/' OCaml.mk || die "sed failed"
+ sed -i -e 's/ \$(LIBRARY)\.cmxa//' OCaml.mk || die "sed failed"
+ sed -i -e 's/ \$(LIBRARY)\.a//' OCaml.mk || die "sed failed"
+ sed -i -e 's/) \$(NCOBJECTS)/)/' OCaml.mk || die "sed failed"
+ fi
+}
+
+src_compile() {
+ #parallel fails
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ use ocamlopt || export STRIP_MASK="*bin/schoca"
+ dodir "$(ocamlfind printconf destdir)" || die "dodir failed"
+ emake PREFIX="/usr" DESTDIR="${D}" DESTDIRFLAG="-destdir ${D}$(ocamlfind printconf destdir)" install || die "emake install failed"
+}