summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-16 21:08:46 +0000
committerSam James <sam@gentoo.org>2021-01-16 21:12:30 +0000
commit3b341e67632441348e9f4eb2d5b82f97282e0799 (patch)
treed87dbc2af92cbc3fc65c5839fbc7f1f8a47789ac /dev-tex
parentnet-fs/openafs: update kernel version check (diff)
downloadgentoo-3b341e67632441348e9f4eb2d5b82f97282e0799.tar.gz
gentoo-3b341e67632441348e9f4eb2d5b82f97282e0799.tar.bz2
gentoo-3b341e67632441348e9f4eb2d5b82f97282e0799.zip
dev-tex/hevea: bump to 2.35
Closes: https://bugs.gentoo.org/750962 Closes: https://bugs.gentoo.org/750761 Closes: https://bugs.gentoo.org/734350 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/hevea/Manifest1
-rw-r--r--dev-tex/hevea/hevea-2.35.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-tex/hevea/Manifest b/dev-tex/hevea/Manifest
index fc3d98cfcdcd..f78a06497411 100644
--- a/dev-tex/hevea/Manifest
+++ b/dev-tex/hevea/Manifest
@@ -1 +1,2 @@
DIST hevea-2.31.tar.gz 965678 BLAKE2B 770a3ff5b3e209d1e34e68647baffc064cb78f63a610e6b81181a829837861984f22e381cc17c34a3b0b4643c260a5cb84841cd8e2038e40083bba7ffbdab929 SHA512 4b66030f69b8b60750f8e62a9d81240b0ba399af8af69df10b33742e10d23fe7aef3e7782265fac9705f27715e5964debd47b9da7a394f70fda947b5fcd2d6ea
+DIST hevea-2.35.tar.gz 1006773 BLAKE2B 80a8f80955a4eee641c53784cbe4543072062d0bf4d757fe0c8270d6370d54495eeab3a9279bd992dc45b80b23de0438ee4fe6fa932981c777b25782c42ca4a8 SHA512 dc1a5179489626176b1fcae47a9c7eb4cf9c1c6127c749cb938808697ccd6179277089fb20f4d5da7b82056d15b1d64acd9ba9884d1950a74d98c98864b4180a
diff --git a/dev-tex/hevea/hevea-2.35.ebuild b/dev-tex/hevea/hevea-2.35.ebuild
new file mode 100644
index 000000000000..d5790789e792
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.35.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://hevea.inria.fr/"
+SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt=]"
+RDEPEND="
+ ${DEPEND}
+ dev-texlive/texlive-latexextra
+"
+BDEPEND="dev-ml/ocamlbuild"
+
+# bug #734350
+QA_FLAGS_IGNORED=(
+ /usr/bin/bibhva
+ /usr/bin/hevea
+ /usr/bin/esponja
+ /usr/bin/hacha
+)
+
+src_compile() {
+ rm -f config.sh || die
+
+ emake PREFIX="${EPREFIX}"/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh
+
+ if use ocamlopt; then
+ emake PREFIX="${EPREFIX}"/usr
+ else
+ emake PREFIX="${EPREFIX}"/usr TARGET=byte
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ else
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr TARGET=byte install
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [[ -z "${ROOT}" ]] && [[ -x "${EPREFIX}"/usr/sbin/texmf-update ]] ; then
+ "${EPREFIX}"/usr/sbin/texmf-update
+ fi
+}
+
+pkg_postrm() {
+ if [[ -z "${ROOT}" ]] && [[ -x "${EPREFIX}"/usr/sbin/texmf-update ]] ; then
+ "${EPREFIX}"/usr/sbin/texmf-update
+ fi
+}