summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-19 02:03:56 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-19 04:09:23 +0100
commitf1407af5391c9b956b78d2128a1d4ff1ac13b30e (patch)
tree4124c5b395d7607120f04d6fd12d61944eb75404 /dev-util/google-perftools
parentapp-backup/dar: Bump to version 2.5.13 (diff)
downloadgentoo-f1407af5391c9b956b78d2128a1d4ff1ac13b30e.tar.gz
gentoo-f1407af5391c9b956b78d2128a1d4ff1ac13b30e.tar.bz2
gentoo-f1407af5391c9b956b78d2128a1d4ff1ac13b30e.zip
dev-util/google-perftools: Bump to version 2.6.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/Manifest1
-rw-r--r--dev-util/google-perftools/google-perftools-2.6.3.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index 197f4b9511d2..b37bddcf8d8a 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -4,4 +4,5 @@ DIST gperftools-2.4.tar.gz 890402 BLAKE2B f4893d7c9bbd3a8dc5b4d8a25837039261fa32
DIST gperftools-2.5.tar.gz 895753 BLAKE2B 5dc01d37255bf94a67603ec597007cad0a7530046b71ceff68581d80df04a84a7acc06083b7a031d73568d04269b2019c1b670605091f68838a9ac4912e7145f SHA512 974b86eadebe0437f4b7cf51de84afa315390cdcd2a88c8ccc8448b0b3e98c2241d89b4987b5fca1937102ae00a43802d9d06d7b11272e3dfeeaa23cf58ad68d
DIST gperftools-2.6.1.tar.gz 907916 BLAKE2B f9726834bb91492df6ebb0903bebc5ecc9e5d521214449e2fec22d4404ff9d2bbbf08b5200fda9452bff17a92363c680502a9c2de3c8f0081f9ba63dcff2c321 SHA512 49c1123ef8e297381e30fae6fc2391539ac5e1d3097b3f9f59c21853589152e248e92be0739bc50da6e5542f2638a9719b88f2d454221f463915d89e569776d2
DIST gperftools-2.6.2.tar.gz 911744 BLAKE2B e5798a2f0f2973f02bccabb2550a9df54319e505fc715795cd836ced631b29bfd8e6f8ddf3c7f6dceb0f166523bb0fa55564b1cbc896c8cd8cfd475263c07c39 SHA512 20c3460f806c6425d54e8d1020f15bc8940aacd7bf1367b03a116fb873bbd6c1e1fbb75df1d0ca341eaec813552fec394327175115ea8442a4b7a1ef17f0df2f
+DIST gperftools-2.6.3.tar.gz 911813 BLAKE2B dae223927835f65b819836b25595df2943a0762ac3b6346e3d0186dab486cfa3e4eabc1f5a2ec43314f53ea96a68acb75991b76055591395bc52e78f655630d3 SHA512 6418c382760c8870ef42a535fcb65a623c1a9fd3ab58fcb7cfe2dd5048b2268b434427da36bc0c76beef2c28e13a6926d32d67084d8ca6675b78650a62de77a7
DIST gperftools-2.6.tar.gz 906841 BLAKE2B 811c722aafdc6ed88a23391bce97f1edcfb0d2c2d301080aa1d567feac46c4866cb63e0ff19158cd321ec0ab6c64f8a6d2138ea0634c30bb85acb26d7309e095 SHA512 9fc32066304b76ad323e90ce2e7b437e7f1a5094b8d40a0e3df4d317fd57b4c048a19dacb7d148bd40557a080b0b82fe2da8ef32ae5511735ca7118e06b1ee38
diff --git a/dev-util/google-perftools/google-perftools-2.6.3.ebuild b/dev-util/google-perftools/google-perftools-2.6.3.ebuild
new file mode 100644
index 000000000000..708d67991674
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-2.6.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="gperftools-${PV}"
+inherit toolchain-funcs flag-o-matic vcs-snapshot autotools multilib-minimal
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="https://github.com/gperftools/gperftools"
+SRC_URI="https://github.com/gperftools/gperftools/tarball/${MY_P} -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+# contains ASM code, with support for
+# freebsd x86/amd64
+# linux x86/amd64/ppc/ppc64/arm
+# OSX ppc/amd64
+# AIX ppc/ppc64
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="largepages +debug minimal optimisememory test static-libs"
+
+DEPEND="sys-libs/libunwind"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+HTML_DOCS="docs"
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+ use test || \
+ MAKEOPTS+=" noinst_PROGRAMS= "
+}
+
+src_prepare() {
+ default
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
+ use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
+
+ econf \
+ --htmldir=${EPREFIX}/usr/share/doc/${PF}/html \
+ --docdir=${EPREFIX}/usr/share/doc/${PF} \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable debug debugalloc) \
+ $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
+}
+
+src_test() {
+ case "${LD_PRELOAD}" in
+ *libsandbox*)
+ ewarn "Unable to run tests when sandbox is enabled."
+ ewarn "See https://bugs.gentoo.org/290249"
+ return 0
+ ;;
+ esac
+
+ multilib-minimal_src_test
+}
+
+src_install() {
+ if ! use minimal && has x32 ${MULTILIB_ABIS}; then
+ MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/gperftools/heap-checker.h
+ /usr/include/gperftools/heap-profiler.h
+ /usr/include/gperftools/stacktrace.h
+ /usr/include/gperftools/profiler.h
+ )
+ fi
+
+ multilib-minimal_src_install
+}