summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-29 14:37:48 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-29 14:37:48 +0100
commit1af99288044f0d9e79befb4f5e6d1bde0db7df61 (patch)
treeb113ac391116ab0bde8a3b7bbb35e0bb6f719eb8 /dev-util/lttng-tools/lttng-tools-2.12.0.ebuild
parentdev-util/lttng-ust: cleanup old versions (diff)
downloadgentoo-1af99288044f0d9e79befb4f5e6d1bde0db7df61.tar.gz
gentoo-1af99288044f0d9e79befb4f5e6d1bde0db7df61.tar.bz2
gentoo-1af99288044f0d9e79befb4f5e6d1bde0db7df61.zip
dev-util/lttng-tools: bump to 2.12.0
Closes: https://bugs.gentoo.org/706864 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-util/lttng-tools/lttng-tools-2.12.0.ebuild')
-rw-r--r--dev-util/lttng-tools/lttng-tools-2.12.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/lttng-tools/lttng-tools-2.12.0.ebuild b/dev-util/lttng-tools/lttng-tools-2.12.0.ebuild
new file mode 100644
index 000000000000..be88227c25ae
--- /dev/null
+++ b/dev-util/lttng-tools/lttng-tools-2.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="Linux Trace Toolkit - next generation"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ust"
+
+DEPEND="dev-libs/userspace-rcu:=
+ dev-libs/popt
+ dev-libs/libxml2
+ ust? ( >=dev-util/lttng-ust-2.12.0:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ econf $(usex ust "" --without-lttng-ust) --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}