summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-12-27 17:18:30 -0800
committerSam James <sam@gentoo.org>2023-01-15 14:16:14 +0000
commit029355058d22515f731f4199cad01b4ad5425dff (patch)
tree824cb9da14c432409943e174be18140d58d75874 /games-emulation
parentgames-emulation/mgba-jg: New package, v0.10.1 (diff)
downloadgentoo-029355058d22515f731f4199cad01b4ad5425dff.tar.gz
gentoo-029355058d22515f731f4199cad01b4ad5425dff.tar.bz2
gentoo-029355058d22515f731f4199cad01b4ad5425dff.zip
games-emulation/nestopia-jg: New package, v1.52.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestopia-jg/Manifest1
-rw-r--r--games-emulation/nestopia-jg/metadata.xml22
-rw-r--r--games-emulation/nestopia-jg/nestopia-jg-1.52.0.ebuild45
-rw-r--r--games-emulation/nestopia-jg/nestopia-jg-9999.ebuild45
4 files changed, 113 insertions, 0 deletions
diff --git a/games-emulation/nestopia-jg/Manifest b/games-emulation/nestopia-jg/Manifest
new file mode 100644
index 000000000000..0c597bb9c93a
--- /dev/null
+++ b/games-emulation/nestopia-jg/Manifest
@@ -0,0 +1 @@
+DIST nestopia-1.52.0.tar.bz2 451267 BLAKE2B a70e1251a5b9dcb17a5d8e8233c12cc90189a0471aa3faf955c15d7331e44c4a67d6ddd101326820c219c3b5e09780a7191a45c14267e6da156d968a5b9bfce0 SHA512 5b2876ec3dcc90b94b99184d964bdeee8f194e07f8b8efeb9f425a118c3cc51e3d54901d922988047bfcb7fa5f3be97ed4e694c1451046a98e99678625d1f6f4
diff --git a/games-emulation/nestopia-jg/metadata.xml b/games-emulation/nestopia-jg/metadata.xml
new file mode 100644
index 000000000000..6150882ce3c3
--- /dev/null
+++ b/games-emulation/nestopia-jg/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Nestopia JG is an emulator for the Nintendo Entertainment
+ System/Famicom, including support for the Famicom Disk
+ System. Though originally a fork, Nestopia JG is now the
+ de facto upstream branch of the Nestopia emulator.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://gitlab.com/jgemu/nestopia/-/issues</bugs-to>
+ <remote-id type="gitlab">jgemu/nestopia</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-emulation/nestopia-jg/nestopia-jg-1.52.0.ebuild b/games-emulation/nestopia-jg/nestopia-jg-1.52.0.ebuild
new file mode 100644
index 000000000000..ed6cc71cbb13
--- /dev/null
+++ b/games-emulation/nestopia-jg/nestopia-jg-1.52.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of Nestopia"
+HOMEPAGE="https://gitlab.com/jgemu/nestopia"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}
diff --git a/games-emulation/nestopia-jg/nestopia-jg-9999.ebuild b/games-emulation/nestopia-jg/nestopia-jg-9999.ebuild
new file mode 100644
index 000000000000..ed6cc71cbb13
--- /dev/null
+++ b/games-emulation/nestopia-jg/nestopia-jg-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Fork of Nestopia"
+HOMEPAGE="https://gitlab.com/jgemu/nestopia"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}