summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-13 23:20:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-13 23:21:07 +0100
commitf5b25c9fd1c98384788a00adfba5e519b6c91551 (patch)
tree5077ffcbd14b45a4a5fc26419e63affb3c30d52d /games-engines/box2d
parentnet-im/teams: Remove old (diff)
downloadgentoo-f5b25c9fd1c98384788a00adfba5e519b6c91551.tar.gz
gentoo-f5b25c9fd1c98384788a00adfba5e519b6c91551.tar.bz2
gentoo-f5b25c9fd1c98384788a00adfba5e519b6c91551.zip
games-engines/box2d: Add IUSE=doc, set BOX2D_BUILD_TESTBED=OFF
Closes: https://bugs.gentoo.org/775854 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-engines/box2d')
-rw-r--r--games-engines/box2d/box2d-2.4.1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/games-engines/box2d/box2d-2.4.1.ebuild b/games-engines/box2d/box2d-2.4.1.ebuild
index 60c6f3ccd48e..e75f1f087678 100644
--- a/games-engines/box2d/box2d-2.4.1.ebuild
+++ b/games-engines/box2d/box2d-2.4.1.ebuild
@@ -12,3 +12,14 @@ SRC_URI="https://github.com/erincatto/Box2D/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOX2D_BUILD_TESTBED=OFF # bundled libs, broken anyway right now
+ -DBOX2D_BUILD_DOCS=$(usex doc)
+ )
+ cmake_src_configure
+}