summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-engines/solarus
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-engines/solarus')
-rw-r--r--games-engines/solarus/Manifest1
-rw-r--r--games-engines/solarus/metadata.xml12
-rw-r--r--games-engines/solarus/solarus-1.3.1.ebuild56
3 files changed, 69 insertions, 0 deletions
diff --git a/games-engines/solarus/Manifest b/games-engines/solarus/Manifest
new file mode 100644
index 000000000000..9d4d755ea4be
--- /dev/null
+++ b/games-engines/solarus/Manifest
@@ -0,0 +1 @@
+DIST solarus-1.3.1-src.tar.gz 2450599 SHA256 bfdbd909b817722985393869b1e8c18f18081fd0c68b4c3189c50ef0bbc8f55c SHA512 f52a46add1432a98931db8d26496371b5ff843151c8ac0fdaf1e774be37399d9be6c401f263a65aa08b96f3eebda367b4ccb07ef6cb9740b3112b01e4763556b WHIRLPOOL 67b92a03d2d0a69376f63b9aae3367b97d7d34d40ce3e14d835c34333dc0ec9600bb6ff39f19f31b2861f0b3f790bdb2234bbd7df4b04cca443bb2695a7bcdf6
diff --git a/games-engines/solarus/metadata.xml b/games-engines/solarus/metadata.xml
new file mode 100644
index 000000000000..302d78c256a5
--- /dev/null
+++ b/games-engines/solarus/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='doc'>Install doxygen developer documentation.</flag>
+ <flag name='luajit'>Use LuaJIT instead of default Lua.</flag>
+ </use>
+ <upstream>
+ <remote-id type='github'>christopho/solarus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-engines/solarus/solarus-1.3.1.ebuild b/games-engines/solarus/solarus-1.3.1.ebuild
new file mode 100644
index 000000000000..74f5379af9bb
--- /dev/null
+++ b/games-engines/solarus/solarus-1.3.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils games
+
+DESCRIPTION="An open-source Zelda-like 2D game engine"
+HOMEPAGE="http://www.solarus-games.org/"
+SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc luajit"
+
+RDEPEND="
+ dev-games/physfs
+ media-libs/libmodplug
+ >=media-libs/libsdl2-2.0.1[X,joystick,video]
+ media-libs/libvorbis
+ media-libs/openal
+ media-libs/sdl2-image[png]
+ >=media-libs/sdl2-ttf-2.0.12
+ luajit? ( dev-lang/luajit:2 )
+ !luajit? ( dev-lang/lua:0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSOLARUS_INSTALL_DESTINATION="${GAMES_BINDIR}"
+ $(cmake-utils_use luajit SOLARUS_USE_LUAJIT)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd doc || die
+ doxygen || die
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ doman solarus.6
+ use doc && dohtml -r doc/${PV%.*}/html/*
+ prepgamesdirs
+}