summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-04-01 21:10:31 +0200
committerJames Le Cuirot <chewi@gentoo.org>2022-04-02 10:02:37 +0100
commita9e4b52409935d31b8fa5d8275eb33124c98aa5d (patch)
tree89075fb5f7909714352560c72e9c4eae9495f10f /games-fps
parentdev-ruby/ffi: drop 1.15.1-r1, 1.15.3-r1, 1.15.4-r1 (diff)
downloadgentoo-a9e4b52409935d31b8fa5d8275eb33124c98aa5d.tar.gz
gentoo-a9e4b52409935d31b8fa5d8275eb33124c98aa5d.tar.bz2
gentoo-a9e4b52409935d31b8fa5d8275eb33124c98aa5d.zip
games-fps/rott: EAPI8 bump, use HTTPS, fix calling cc directly
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/24855 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/rott/rott-1.1.2-r1.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/games-fps/rott/rott-1.1.2-r1.ebuild b/games-fps/rott/rott-1.1.2-r1.ebuild
index 915ad6efa315..a11a0d2074c1 100644
--- a/games-fps/rott/rott-1.1.2-r1.ebuild
+++ b/games-fps/rott/rott-1.1.2-r1.ebuild
@@ -1,24 +1,27 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit toolchain-funcs
DESCRIPTION="Rise of the Triad for Linux!"
-HOMEPAGE="http://www.icculus.org/rott/"
-SRC_URI="http://www.icculus.org/rott/releases/${P}.tar.gz
+HOMEPAGE="https://www.icculus.org/rott/"
+SRC_URI="https://www.icculus.org/rott/releases/${P}.tar.gz
demo? ( http://filesingularity.timedoctor.org/swdata.zip )"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="demo"
-RDEPEND="media-libs/libsdl[sound,joystick,video]
+RDEPEND="
+ media-libs/libsdl[sound,joystick,video]
media-libs/sdl-mixer"
DEPEND="${RDEPEND}
app-arch/unzip"
-S=${WORKDIR}/${P}/rott
+S="${WORKDIR}/${P}/rott"
src_prepare() {
default
@@ -30,6 +33,7 @@ src_prepare() {
}
src_compile() {
+ tc-export CC
emake -j1 \
EXTRACFLAGS="${CFLAGS} -DDATADIR=\\\"/usr/share/${PN}/\\\"" \
SHAREWARE=$(usex demo "1" "0")