summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/hexalate
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/hexalate')
-rw-r--r--games-puzzle/hexalate/Manifest1
-rw-r--r--games-puzzle/hexalate/files/hexalate-1.0.3-gentoo.patch11
-rw-r--r--games-puzzle/hexalate/hexalate-1.0.3.ebuild51
-rw-r--r--games-puzzle/hexalate/metadata.xml5
4 files changed, 68 insertions, 0 deletions
diff --git a/games-puzzle/hexalate/Manifest b/games-puzzle/hexalate/Manifest
new file mode 100644
index 000000000000..aa93bbb05897
--- /dev/null
+++ b/games-puzzle/hexalate/Manifest
@@ -0,0 +1 @@
+DIST hexalate-1.0.3-src.tar.bz2 336589 SHA256 a391ba44aa0f5bd618385dbe17e059947b829b85315aecb19edd1c863b3ebe3c SHA512 582e41ef298788e73e4f39976dbf334fdb514518e53556b77bd2a7f49d82f66617e21ab5ff24a298313e529aa147e80703fe9eb40318d9b74673dd6fcf32d909 WHIRLPOOL 4ce78bf4cb37346b4722f647e4dbda4fe3c88138264b8ad758302152cc199d7374f0cfadb8497ad767aae678345910701bc30f12ef7eb1b0e691a1df73fc40bf
diff --git a/games-puzzle/hexalate/files/hexalate-1.0.3-gentoo.patch b/games-puzzle/hexalate/files/hexalate-1.0.3-gentoo.patch
new file mode 100644
index 000000000000..49f5b1c82ee5
--- /dev/null
+++ b/games-puzzle/hexalate/files/hexalate-1.0.3-gentoo.patch
@@ -0,0 +1,11 @@
+--- src/locale_dialog.cpp.old 2014-05-20 22:30:07.399795787 +0200
++++ src/locale_dialog.cpp 2014-05-20 22:31:12.079600999 +0200
+@@ -85,7 +85,7 @@
+ if (paths.isEmpty()) {
+ QString appdir = QCoreApplication::applicationDirPath();
+ paths.append(appdir);
+- paths.append(appdir + "/../share/" + QCoreApplication::applicationName().toLower());
++ paths.append("@GENTOO_DATADIR@");
+ paths.append(appdir + "/../Resources");
+ }
+ foreach (const QString& path, paths) {
diff --git a/games-puzzle/hexalate/hexalate-1.0.3.ebuild b/games-puzzle/hexalate/hexalate-1.0.3.ebuild
new file mode 100644
index 000000000000..65c9d3f838ee
--- /dev/null
+++ b/games-puzzle/hexalate/hexalate-1.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+LANGS="ca cs de el en es et fr hu ms nl pl ro ru tr"
+LANGSLONG="pt_BR"
+inherit eutils qt4-r2 games
+
+DESCRIPTION="A color matching game"
+HOMEPAGE="http://gottcode.org/hexalate/"
+SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ src/locale_dialog.cpp \
+ || die "sed failed"
+}
+
+src_configure() {
+ qt4-r2_src_configure
+}
+
+src_install() {
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}"/${PN}/translations/
+ for lang in ${LINGUAS};do
+ for x in ${LANGS};do
+ if [[ ${lang} == ${x} ]];then
+ doins translations/${PN}_${x}.qm
+ fi
+ done
+ done
+ insinto /usr/share/icons
+ doins -r icons/hicolor
+ dodoc CREDITS ChangeLog NEWS README
+ doicon icons/${PN}.xpm
+ domenu icons/${PN}.desktop
+ prepgamesdirs
+}
diff --git a/games-puzzle/hexalate/metadata.xml b/games-puzzle/hexalate/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/hexalate/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>