summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-03 15:49:06 +0100
commit128c4b0b6c73f994174bf351d311ed021adbc6f7 (patch)
treeb29ea0b846a53af1bc54ded701368dd2ff5f638a /games-strategy
parentwww-apps/prowlarr: drop 1.0.0.2171 (diff)
downloadgentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.gz
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.tar.bz2
gentoo-128c4b0b6c73f994174bf351d311ed021adbc6f7.zip
*/*: make mycmakeargs local
Closes: https://github.com/gentoo/gentoo/pull/28947 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/wesnoth-1.16.6.ebuild8
-rw-r--r--games-strategy/wesnoth/wesnoth-1.17.11.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/games-strategy/wesnoth/wesnoth-1.16.6.ebuild b/games-strategy/wesnoth/wesnoth-1.16.6.ebuild
index 1a92e4f2d992..f8edac88d9d7 100644
--- a/games-strategy/wesnoth/wesnoth-1.16.6.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.16.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -67,8 +67,10 @@ src_prepare() {
src_configure() {
filter-flags -ftracer -fomit-frame-pointer
+ local mycmakeargs=()
+
if use dedicated || use server ; then
- mycmakeargs=(
+ mycmakeargs+=(
-DENABLE_CAMPAIGN_SERVER="ON"
-DENABLE_SERVER="ON"
-DSERVER_UID="${PN}"
@@ -76,7 +78,7 @@ src_configure() {
-DFIFO_DIR="/run/wesnothd"
)
else
- mycmakeargs=(
+ mycmakeargs+=(
-DENABLE_CAMPAIGN_SERVER="OFF"
-DENABLE_SERVER="OFF"
)
diff --git a/games-strategy/wesnoth/wesnoth-1.17.11.ebuild b/games-strategy/wesnoth/wesnoth-1.17.11.ebuild
index 5724bdef29fa..834aa1c3259c 100644
--- a/games-strategy/wesnoth/wesnoth-1.17.11.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.17.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -65,8 +65,10 @@ src_prepare() {
src_configure() {
filter-flags -ftracer -fomit-frame-pointer
+ local mycmakeargs=()
+
if use dedicated || use server ; then
- mycmakeargs=(
+ mycmakeargs+=(
-DENABLE_CAMPAIGN_SERVER="ON"
-DENABLE_SERVER="ON"
-DSERVER_UID="${PN}"
@@ -74,7 +76,7 @@ src_configure() {
-DFIFO_DIR="/run/wesnothd"
)
else
- mycmakeargs=(
+ mycmakeargs+=(
-DENABLE_CAMPAIGN_SERVER="OFF"
-DENABLE_SERVER="OFF"
)