summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-30 15:38:47 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-03-30 15:39:40 +0200
commitc228bd4013604733680344ce4029afcf1e4a274d (patch)
treed03875a31031b95d57a7f1ec4d2c1e94d2112413 /media-gfx/ansilove
parentmedia-gfx/ansilove: bump to 4.1.7 (diff)
downloadgentoo-c228bd4013604733680344ce4029afcf1e4a274d.tar.gz
gentoo-c228bd4013604733680344ce4029afcf1e4a274d.tar.bz2
gentoo-c228bd4013604733680344ce4029afcf1e4a274d.zip
media-gfx/ansilove: sync live; format
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'media-gfx/ansilove')
-rw-r--r--media-gfx/ansilove/ansilove-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/media-gfx/ansilove/ansilove-9999.ebuild b/media-gfx/ansilove/ansilove-9999.ebuild
index e593f48c0fb9..d0d4327ea128 100644
--- a/media-gfx/ansilove/ansilove-9999.ebuild
+++ b/media-gfx/ansilove/ansilove-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,13 +6,15 @@ EAPI=8
inherit cmake
DESCRIPTION="ANSI and ASCII art to PNG converter (using libansilove)"
-HOMEPAGE="https://github.com/ansilove/ansilove/"
+HOMEPAGE="https://www.ansilove.org/
+ https://github.com/ansilove/ansilove/"
-if [[ "${PV}" == *9999* ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/ansilove/${PN}.git"
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
else
- SRC_URI="https://github.com/ansilove/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi
@@ -23,7 +25,7 @@ RDEPEND="dev-libs/libansilove"
DEPEND="${RDEPEND}"
src_configure() {
- local mycmakeargs=(
+ local -a mycmakeargs=(
-DENABLE_SECCOMP=NO
)
cmake_src_configure