summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-21 06:38:02 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-21 06:38:02 +0100
commitc1bf75e0561c12f8f6ebaeee2d3bf8349fc3eb0d (patch)
treef0e634d176605f40465a950b6b452837f59f5f6a /media-gfx/cairosvg
parentpypi.eclass: Introduce PYPI_PN to override the default project name (diff)
downloadgentoo-c1bf75e0561c12f8f6ebaeee2d3bf8349fc3eb0d.tar.gz
gentoo-c1bf75e0561c12f8f6ebaeee2d3bf8349fc3eb0d.tar.bz2
gentoo-c1bf75e0561c12f8f6ebaeee2d3bf8349fc3eb0d.zip
media-gfx/cairosvg: Bump to 2.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-gfx/cairosvg')
-rw-r--r--media-gfx/cairosvg/Manifest1
-rw-r--r--media-gfx/cairosvg/cairosvg-2.7.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/cairosvg/Manifest b/media-gfx/cairosvg/Manifest
index db1a46b0a071..4317383778f8 100644
--- a/media-gfx/cairosvg/Manifest
+++ b/media-gfx/cairosvg/Manifest
@@ -1 +1,2 @@
DIST CairoSVG-2.6.0.tar.gz 8398114 BLAKE2B d4aca284fe3756c40c62dfb2b29e4670c947df13dd76e5104a13cb963bbdf6aa1f7fd242748d6fd0ca524aa03578c3449fa8ea6d86b9a8ce4a64976c32e96627 SHA512 dc504233a8f3fccfc8d4082328bfc0f06a4ebe0249801f764b9aed6b3bad5f953786352930ab199b10b301d0f44a8c2ef2e79eeea198c9094e697fdaa4db48d5
+DIST CairoSVG-2.7.0.tar.gz 8398722 BLAKE2B 00a82ec395480aba7bf1c1e2025f53ad5e3bb6336110e709f9cdb67c8a2eeafb071da0dc44aabceadd4c8c274f4560d264c101f43c89c6faa96ea47018a67f62 SHA512 7775654f55ac436c91e781a91ca9ca89826068638fdbf65b9717899dfd5d974dacc7cf2e7ee24fad1be8ded899e1c1f441137f25c2a8185b67e7ecc84c2c9c50
diff --git a/media-gfx/cairosvg/cairosvg-2.7.0.ebuild b/media-gfx/cairosvg/cairosvg-2.7.0.ebuild
new file mode 100644
index 000000000000..eca08d075044
--- /dev/null
+++ b/media-gfx/cairosvg/cairosvg-2.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="CairoSVG"
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CLI and library to export SVG to PDF, PostScript, and PNG"
+HOMEPAGE="
+ https://cairosvg.org/
+ https://github.com/Kozea/CairoSVG/
+ https://pypi.org/project/CairoSVG/
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cairocffi[${PYTHON_USEDEP}]
+ dev-python/cssselect2[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # this test compares output against old version; this makes little
+ # sense for us and requires both distfiles around
+ test_non_regression
+)