summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-16 19:28:55 +0000
committerSam James <sam@gentoo.org>2021-03-16 19:55:46 +0000
commit22694ab77134179d14214e024d931cbc1522aeee (patch)
tree8e7dac619071e97b2a2e44078c1f8f869329cdf9 /media-gfx/libimagequant/libimagequant-2.12.2.ebuild
parentmedia-gfx/gif2png: drop 2.5.9, 2.5.12 (diff)
downloadgentoo-22694ab77134179d14214e024d931cbc1522aeee.tar.gz
gentoo-22694ab77134179d14214e024d931cbc1522aeee.tar.bz2
gentoo-22694ab77134179d14214e024d931cbc1522aeee.zip
media-gfx/libimagequant: drop 2.12.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/libimagequant/libimagequant-2.12.2.ebuild')
-rw-r--r--media-gfx/libimagequant/libimagequant-2.12.2.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/media-gfx/libimagequant/libimagequant-2.12.2.ebuild b/media-gfx/libimagequant/libimagequant-2.12.2.ebuild
deleted file mode 100644
index 5ecbf05fe927..000000000000
--- a/media-gfx/libimagequant/libimagequant-2.12.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Palette quantization library that powers pngquant and other PNG optimizers"
-HOMEPAGE="https://pngquant.org/lib/"
-SRC_URI="https://github.com/ImageOptim/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0/0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="cpu_flags_x86_sse2 debug openmp static-libs"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/libimagequant-2.12.2-respect-CFLAGS.patch
- "${FILESDIR}"/libimagequant-2.12.2-fix-pkgconfig.patch
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- tc-export AR CC
- # Hand rolled configure script, so not all flags are supported.
- ./configure \
- --prefix="${EPREFIX}/usr" \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
- $(use debug && echo --enable-debug) \
- $(use_enable cpu_flags_x86_sse2 sse) \
- $(use_with openmp) \
- CFLAGS="${CFLAGS} ${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
-}
-
-src_compile() {
- emake shared imagequant.pc
- use static-libs && emake static
-}
-
-src_install() {
- dolib.so libimagequant.so
- dolib.so libimagequant.so.*
- use static-libs && dolib.a libimagequant.a
- doheader libimagequant.h
- einstalldocs
- insinto /usr/$(get_libdir)/pkgconfig
- doins imagequant.pc
-}