summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-12-16 21:54:43 -0500
committerTim Harder <radhermit@gentoo.org>2016-12-16 21:54:43 -0500
commit999cb1c7febcfeed5217e47c5cf289fee82817a2 (patch)
tree0328a92853ea9e8b26ae22033a52c76d9247cc0a /media-libs/cimg/cimg-1.7.9.ebuild
parentsys-cluster/heat: cleanup (diff)
downloadgentoo-999cb1c7febcfeed5217e47c5cf289fee82817a2.tar.gz
gentoo-999cb1c7febcfeed5217e47c5cf289fee82817a2.tar.bz2
gentoo-999cb1c7febcfeed5217e47c5cf289fee82817a2.zip
media-libs/cimg: version bump to 1.7.9
Diffstat (limited to 'media-libs/cimg/cimg-1.7.9.ebuild')
-rw-r--r--media-libs/cimg/cimg-1.7.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/media-libs/cimg/cimg-1.7.9.ebuild b/media-libs/cimg/cimg-1.7.9.ebuild
new file mode 100644
index 000000000000..a7732ae5ca13
--- /dev/null
+++ b/media-libs/cimg/cimg-1.7.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PV=${PV//./}
+MY_P="CImg-v.${MY_PV}"
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="http://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodoc README.txt
+ doheader CImg.h
+ use doc && dodoc -r html
+}