summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-08-19 16:18:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2019-08-19 18:40:58 +0200
commit31edf91f5fa254ab29b8a7ea41287cae9e3761ba (patch)
tree24e221c2041f73103c81f9015c01a0c0acad34a5 /media-libs/dav1d
parentmedia-video/ffmpeg: disable harcoded tables in live ebuild (diff)
downloadgentoo-31edf91f5fa254ab29b8a7ea41287cae9e3761ba.tar.gz
gentoo-31edf91f5fa254ab29b8a7ea41287cae9e3761ba.tar.bz2
gentoo-31edf91f5fa254ab29b8a7ea41287cae9e3761ba.zip
media-libs/dav1d: bump to 0.4.0
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs/dav1d')
-rw-r--r--media-libs/dav1d/Manifest1
-rw-r--r--media-libs/dav1d/dav1d-0.4.0.ebuild58
-rw-r--r--media-libs/dav1d/dav1d-9999.ebuild2
3 files changed, 60 insertions, 1 deletions
diff --git a/media-libs/dav1d/Manifest b/media-libs/dav1d/Manifest
index c7f1b42539d6..5f7b01403f15 100644
--- a/media-libs/dav1d/Manifest
+++ b/media-libs/dav1d/Manifest
@@ -3,3 +3,4 @@ DIST dav1d-0.2.0.tar.bz2 408361 BLAKE2B 2c5f4d7777d85ab1453a744335ee5047b2e108a7
DIST dav1d-0.2.1.tar.bz2 412003 BLAKE2B 51520f355f51f7fdc8c6e7981fd29f8d5339c2c72058ea05dff6bf0c3b191cf3c077fee1b46813f229d1bee16d1b884e834a5d61bf78459d83113aafe63bca89 SHA512 38d0a9e639579bf2046d3afd7ba0d4205081d8e26955be0216acc84ee2adcc81c790c858932009965b61a66fc3df66ed6b14da9d0e61e2505418c17bc4b75004
DIST dav1d-0.3.0.tar.bz2 435690 BLAKE2B 57124b2a5bcde8a2de8e4ee8155ec736d2f4c13dc7347029c517d70495de1943feef7f0c7ce1d1051304fe9f3141775fbe07ceec0733fdca3dca166cbab6c417 SHA512 bc0933bbc7064555e8973c82390e414aca8f52a14c5de7ee3ff92c263722d5c9cc472ba5f1f8d1dd60c4ce9ab0ed880c8b4a53b3d33d3aff24bc8e7fb18b0b84
DIST dav1d-0.3.1.tar.bz2 438676 BLAKE2B f51c997fb95abc5b2721d67feb2023daf6bdab8d725b2b52b6c25440dcfab637b8543b8622c18da678eff20bbed155e86da9c9040a98160e5b9381ba7ab5ecf8 SHA512 b810c993a2a262f75ea0d4404428bc5660ac0d4c4d41aa311bc2180abecc40b36e73858f436b27372f4a1a0b7c700df4f8cc535130c663d6bfba2206d549e0f2
+DIST dav1d-0.4.0.tar.bz2 493854 BLAKE2B 8ae022054ab9827306f6e8501e0bfbc03a04e280a3e155c12ae2dfef474eab976097ce3ed990bd5cdbc3ac79018138a156f0701973ac40357224feb75149332a SHA512 7d2ad9959649321e86f9d0dcf44b274251c103fce9f02964d898b6d9da69e38e93bbed86a7ea217c93e0ee89e1ad43bc31dc217535c4b1cc37761191a6585fc1
diff --git a/media-libs/dav1d/dav1d-0.4.0.ebuild b/media-libs/dav1d/dav1d-0.4.0.ebuild
new file mode 100644
index 000000000000..2ac427eee5dc
--- /dev/null
+++ b/media-libs/dav1d/dav1d-0.4.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+SCM=""
+if [[ "${PV}" == "9999" ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+fi
+
+inherit ${SCM} meson ninja-utils multilib-minimal
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+SLOT="0/2"
+IUSE="+8bit +10bit +asm"
+
+ASM_DEPEND=">=dev-lang/nasm-2.13"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )"
+
+DOCS=( README.md doc/PATENTS )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ build_asm=false
+ else
+ build_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -D bitdepths=$(IFS=,; echo "${bits[*]}")
+ -D build_asm=$build_asm
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}
diff --git a/media-libs/dav1d/dav1d-9999.ebuild b/media-libs/dav1d/dav1d-9999.ebuild
index 3315a0dfa4c3..2ac427eee5dc 100644
--- a/media-libs/dav1d/dav1d-9999.ebuild
+++ b/media-libs/dav1d/dav1d-9999.ebuild
@@ -18,7 +18,7 @@ DESCRIPTION="dav1d is an AV1 Decoder :)"
HOMEPAGE="https://code.videolan.org/videolan/dav1d"
LICENSE="BSD-2"
-SLOT="0/1"
+SLOT="0/2"
IUSE="+8bit +10bit +asm"
ASM_DEPEND=">=dev-lang/nasm-2.13"