summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/imlib2_loaders
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/imlib2_loaders')
-rw-r--r--media-plugins/imlib2_loaders/Manifest1
-rw-r--r--media-plugins/imlib2_loaders/imlib2_loaders-1.4.7.ebuild31
-rw-r--r--media-plugins/imlib2_loaders/imlib2_loaders-9999.ebuild31
-rw-r--r--media-plugins/imlib2_loaders/metadata.xml15
4 files changed, 78 insertions, 0 deletions
diff --git a/media-plugins/imlib2_loaders/Manifest b/media-plugins/imlib2_loaders/Manifest
new file mode 100644
index 000000000000..e94798beb028
--- /dev/null
+++ b/media-plugins/imlib2_loaders/Manifest
@@ -0,0 +1 @@
+DIST imlib2_loaders-1.4.7.tar.gz 384739 SHA256 f22745bb8ea610a47651cc7926fea32f641de6c9b5abf15350748bcbc0272fe1 SHA512 c7be31b9a7b50ea5a44cadf0ec7f056f5080498ec53fcd32d82a0a6da163b59397e8470c7bbe536d2cabf88c7694d18b450ad85cc6693e8862aeb7d4ee0f4835 WHIRLPOOL 8ca0c1f2222072328d34ed9d546788ab6c9c4653f78e1230efabad973be4e321c812c85ccfd981d94de106b4624bff30fa979de578f54ca17455ffa8c3fb22ec
diff --git a/media-plugins/imlib2_loaders/imlib2_loaders-1.4.7.ebuild b/media-plugins/imlib2_loaders/imlib2_loaders-1.4.7.ebuild
new file mode 100644
index 000000000000..2495d5cb2758
--- /dev/null
+++ b/media-plugins/imlib2_loaders/imlib2_loaders-1.4.7.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+else
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="image loader plugins for Imlib 2"
+HOMEPAGE="http://www.enlightenment.org/pages/imlib2.html"
+
+IUSE="eet xcf"
+
+RDEPEND=">=media-libs/imlib2-${PV}
+ eet? ( dev-libs/eet )"
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable eet)
+ $(use_enable xcf)
+ )
+
+ enlightenment_src_configure
+}
diff --git a/media-plugins/imlib2_loaders/imlib2_loaders-9999.ebuild b/media-plugins/imlib2_loaders/imlib2_loaders-9999.ebuild
new file mode 100644
index 000000000000..2495d5cb2758
--- /dev/null
+++ b/media-plugins/imlib2_loaders/imlib2_loaders-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+else
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="image loader plugins for Imlib 2"
+HOMEPAGE="http://www.enlightenment.org/pages/imlib2.html"
+
+IUSE="eet xcf"
+
+RDEPEND=">=media-libs/imlib2-${PV}
+ eet? ( dev-libs/eet )"
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable eet)
+ $(use_enable xcf)
+ )
+
+ enlightenment_src_configure
+}
diff --git a/media-plugins/imlib2_loaders/metadata.xml b/media-plugins/imlib2_loaders/metadata.xml
new file mode 100644
index 000000000000..ea2cb0c98801
--- /dev/null
+++ b/media-plugins/imlib2_loaders/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>enlightenment@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="eet">Enable Eet image loader</flag>
+ <flag name="xcf">Enable XCF image loader</flag>
+</use>
+<longdescription>
+additional image library loaders for imlib2
+</longdescription>
+</pkgmetadata>