summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gmtp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gmtp')
-rw-r--r--media-sound/gmtp/Manifest2
-rw-r--r--media-sound/gmtp/gmtp-1.3.5.ebuild44
-rw-r--r--media-sound/gmtp/gmtp-1.3.9.ebuild44
-rw-r--r--media-sound/gmtp/metadata.xml15
4 files changed, 105 insertions, 0 deletions
diff --git a/media-sound/gmtp/Manifest b/media-sound/gmtp/Manifest
new file mode 100644
index 000000000000..33e5f42b19cc
--- /dev/null
+++ b/media-sound/gmtp/Manifest
@@ -0,0 +1,2 @@
+DIST gmtp-1.3.5.tar.gz 1613492 SHA256 ae6950d7157e6b90a46f0f850085c5e2fba628e9e58ba493ba164eb3405f55d3 SHA512 5e6f4b4f5dff0d9d5a2b477a8b174958d660bca046b8904b019540b9fc975be974e3dd261c4ee00ea00a023227a9f641911b46bb94dd7b00ff5354bbb5bdae6a WHIRLPOOL 2fa7747418d1e8a7ba0d8bb661d100e8e9953ec938d4af7e70c82d6dd94c0c714403d5e0cfa3d0b956aa8f940d7991d24e30e99bdafe5b6ff7238425fe0e792b
+DIST gmtp-1.3.9.tar.gz 489612 SHA256 5bff5385db66f5c3e82d89edb7ca4a8ccb8c8954faf7341438080f2741dcbd2d SHA512 e5fc652105d23719cb366bb9292c1520cc0a0e4c10179fec6108145c32725ea2a8e47b10c0bee415327718b3d9e2c2f84e0fda6225e57b472d9eabe4fcb615e0 WHIRLPOOL ca95a0b1a194a6c40bd20916614a75b77f6bf525179fb81bdb8c4788edc0127b0552427e82e335d119907864822f58917be6c07463225f5a17a0ce7c0b001ae0
diff --git a/media-sound/gmtp/gmtp-1.3.5.ebuild b/media-sound/gmtp/gmtp-1.3.5.ebuild
new file mode 100644
index 000000000000..8e04c0967efc
--- /dev/null
+++ b/media-sound/gmtp/gmtp-1.3.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnome2-utils
+
+DESCRIPTION="A simple MTP client for MP3 players"
+HOMEPAGE="http://gmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ media-libs/flac
+ media-libs/libid3tag
+ media-libs/libmtp
+ media-libs/libvorbis
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-gtk3
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/media-sound/gmtp/gmtp-1.3.9.ebuild b/media-sound/gmtp/gmtp-1.3.9.ebuild
new file mode 100644
index 000000000000..0cd14c7fb2fd
--- /dev/null
+++ b/media-sound/gmtp/gmtp-1.3.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnome2-utils
+
+DESCRIPTION="A simple MTP client for MP3 players"
+HOMEPAGE="http://gmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ media-libs/flac
+ media-libs/libid3tag
+ media-libs/libmtp
+ media-libs/libvorbis
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --with-gtk3
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/media-sound/gmtp/metadata.xml b/media-sound/gmtp/metadata.xml
new file mode 100644
index 000000000000..cfe9c2c04f39
--- /dev/null
+++ b/media-sound/gmtp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+ </maintainer>
+ <herd>sound</herd>
+ <longdescription lang="en">
+gMTP is a graphical frontend to libmtp. It allows to transfer files to mtp devices like mp3 players or android tablets.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">gmtp</remote-id>
+ </upstream>
+</pkgmetadata>