summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-14 18:43:24 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-14 19:07:53 +0200
commit2c542c510f16890a3c77659123a0e2a42845d28e (patch)
tree7aa92e1122a7a58a026b99ee326a55a745f6004c /media-sound
parentkde-frameworks/kross: 5.85.0 version bump (diff)
downloadgentoo-2c542c510f16890a3c77659123a0e2a42845d28e.tar.gz
gentoo-2c542c510f16890a3c77659123a0e2a42845d28e.tar.bz2
gentoo-2c542c510f16890a3c77659123a0e2a42845d28e.zip
media-sound/cantata: Fix build with musl libc again
See also: https://github.com/CDrummond/cantata/pull/1732 Reported-by: ernsteiswuerfel <erhard_f@mailbox.org> Tested-by: ernsteiswuerfel <erhard_f@mailbox.org> Closes: https://bugs.gentoo.org/807763 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/cantata/cantata-2.4.2.ebuild12
-rw-r--r--media-sound/cantata/files/cantata-2.4.2-main-musl.patch34
2 files changed, 40 insertions, 6 deletions
diff --git a/media-sound/cantata/cantata-2.4.2.ebuild b/media-sound/cantata/cantata-2.4.2.ebuild
index 19e2a7c4abd3..0b6da7338566 100644
--- a/media-sound/cantata/cantata-2.4.2.ebuild
+++ b/media-sound/cantata/cantata-2.4.2.ebuild
@@ -23,10 +23,9 @@ REQUIRED_USE="
musicbrainz? ( || ( cdio cdda ) taglib )
replaygain? ( taglib )
"
+# cantata has no tests
+RESTRICT="test"
-BDEPEND="
- dev-qt/linguist-tools:5
-"
COMMON_DEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -62,13 +61,14 @@ RDEPEND="${COMMON_DEPEND}
DEPEND="${COMMON_DEPEND}
dev-qt/qtconcurrent:5
"
-
-# cantata has no tests
-RESTRICT="test"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
PATCHES=(
"${FILESDIR}/${PN}-2.2.0-headers.patch"
"${FILESDIR}/${P}-solid-musl.patch" # bug 792555
+ "${FILESDIR}/${P}-main-musl.patch" # bug 807763
)
src_prepare() {
diff --git a/media-sound/cantata/files/cantata-2.4.2-main-musl.patch b/media-sound/cantata/files/cantata-2.4.2-main-musl.patch
new file mode 100644
index 000000000000..492dc815854a
--- /dev/null
+++ b/media-sound/cantata/files/cantata-2.4.2-main-musl.patch
@@ -0,0 +1,34 @@
+From d837de8669a2c0eee835d81d9105e21172c8efc0 Mon Sep 17 00:00:00 2001
+From: Helmut Pozimski <helmut@pozimski.eu>
+Date: Sat, 16 Jun 2018 10:01:19 +0200
+Subject: [PATCH] Fix gui/main.cpp build with musl
+
+Picked from VoidLinux:
+
+https://github.com/void-linux/void-packages/commit/188bc4852af59e20f60b186e7acaaaa4b8ce51ab#diff-413d61b1a38989fbf79759fb57901b99d629706587f21aa4b1b19fb8ef23fd4b
+---
+ gui/main.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/gui/main.cpp b/gui/main.cpp
+index 3424e94f7..f3851a0ef 100644
+--- a/gui/main.cpp
++++ b/gui/main.cpp
+@@ -266,7 +266,7 @@ static void installDebugMessageHandler(const QString &cmdLine)
+ qInstallMessageHandler(cantataQtMsgHandler);
+ }
+
+-#if defined Q_OS_LINUX && defined __GNUC__
++#if defined Q_OS_LINUX && defined __GNUC__ && defined __GLIBC__
+ #include <execinfo.h>
+ #include <unistd.h>
+ #include <signal.h>
+@@ -346,7 +346,7 @@ static void sigHandler(int i)
+
+ int main(int argc, char *argv[])
+ {
+- #if defined Q_OS_LINUX && defined __GNUC__
++ #if defined Q_OS_LINUX && defined __GNUC__ && defined __GLIBC__
+ signal(SIGSEGV, sigHandler);
+ #endif
+ QThread::currentThread()->setObjectName("GUI");