summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-23 09:32:57 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-23 10:18:11 +0100
commit500fb42c0284932b3d08e04a69ecfb78ca1be673 (patch)
tree7911735a96ab68570271c2c2927510b375d6af68 /net-analyzer/hunt/hunt-1.5_p6_p1.ebuild
parentnet-misc/dhcp: Bump to version 4.4.2 (diff)
downloadgentoo-500fb42c0284932b3d08e04a69ecfb78ca1be673.tar.gz
gentoo-500fb42c0284932b3d08e04a69ecfb78ca1be673.tar.bz2
gentoo-500fb42c0284932b3d08e04a69ecfb78ca1be673.zip
net-analyzer/hunt: Version 1.5_p6_p1
- Apply Debian patch 6.1 - Build and install tpserv/transproxy - EAPI=7 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/hunt/hunt-1.5_p6_p1.ebuild')
-rw-r--r--net-analyzer/hunt/hunt-1.5_p6_p1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/hunt/hunt-1.5_p6_p1.ebuild b/net-analyzer/hunt/hunt-1.5_p6_p1.ebuild
new file mode 100644
index 000000000000..bdcca2f3eaf8
--- /dev/null
+++ b/net-analyzer/hunt/hunt-1.5_p6_p1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="tool for checking well known weaknesses in the TCP/IP protocol"
+HOMEPAGE="http://lin.fsid.cvut.cz/~kra/index.html"
+SRC_URI="
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-$(ver_cut 4).$(ver_cut 6).diff.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+PATCHES=(
+ "${FILESDIR}"/${P/_p*}-exit.patch
+ "${FILESDIR}"/${P/_p*}-gentoo.patch
+ "${FILESDIR}"/${P/_p*}-log2.patch
+ "${FILESDIR}"/${P/_p*}-tpserv-log.patch
+)
+S=${WORKDIR}/${P/_p*}
+
+src_prepare() {
+ eapply "${WORKDIR}"/${PN}_${PV/_p*}-$(ver_cut 4).$(ver_cut 6).diff
+ default
+}
+
+src_configure() {
+ append-cppflags -DSYNC_FAST
+}
+
+src_compile() {
+ local target
+ for target in . tpserv; do
+ emake CC=$(tc-getCC) LDFLAGS="${CFLAGS} ${LDFLAGS}" -C "${target}"
+ done
+}
+
+src_install() {
+ dosbin hunt tpserv/tpserv tpsetup/transproxy
+ doman man/hunt.1
+ dodoc CHANGES README* TODO tpsetup/transproxy
+ newdoc debian/changelog debian.changelog
+}