summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2020-01-27 18:44:56 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2020-01-27 21:31:16 -0500
commitc9a5da79c40937e2cf8d91e9a8ea0e4d4c4d5329 (patch)
treeb69123332fca79042904302450cc15d8a0c46618 /net-fs
parentx11-wm/xpra: drop dbus removal patch from 3.0.5. (diff)
downloadgentoo-c9a5da79c40937e2cf8d91e9a8ea0e4d4c4d5329.tar.gz
gentoo-c9a5da79c40937e2cf8d91e9a8ea0e4d4c4d5329.tar.bz2
gentoo-c9a5da79c40937e2cf8d91e9a8ea0e4d4c4d5329.zip
net-fs/davfs2: fix building with gcc 10 #706356
Closes: https://bugs.gentoo.org/706356 Bug: http://savannah.nongnu.org/support/index.php?110186 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/davfs2/davfs2-1.5.5.ebuild5
-rw-r--r--net-fs/davfs2/files/davfs2-1.5.5-gcc-10.patch18
2 files changed, 22 insertions, 1 deletions
diff --git a/net-fs/davfs2/davfs2-1.5.5.ebuild b/net-fs/davfs2/davfs2-1.5.5.ebuild
index 3ef5dd25f003..e90fe83a11dd 100644
--- a/net-fs/davfs2/davfs2-1.5.5.ebuild
+++ b/net-fs/davfs2/davfs2-1.5.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,6 +33,9 @@ src_prepare() {
sed -e '/^manual[58]_DATA/ s/\.gz//g' \
-i "${S}"/man/Makefile.in || die
+ # Bug: https://bugs.gentoo.org/706356
+ eapply "${FILESDIR}"/${PN}-1.5.5-gcc-10.patch
+
default
}
diff --git a/net-fs/davfs2/files/davfs2-1.5.5-gcc-10.patch b/net-fs/davfs2/files/davfs2-1.5.5-gcc-10.patch
new file mode 100644
index 000000000000..56b0bab44918
--- /dev/null
+++ b/net-fs/davfs2/files/davfs2-1.5.5-gcc-10.patch
@@ -0,0 +1,18 @@
+Handle building with '-fno-common' for gcc 10.
+See: https://bugs.gentoo.org/706356
+
+
+--- a/src/dav_coda.c
++++ b/src/dav_coda.c
+@@ -99,3 +99,3 @@ static size_t alignment;
+ /* Send debug messages to syslog if != 0. */
+-int debug;
++static int debug;
+
+--- a/src/dav_fuse.c
++++ b/src/dav_fuse.c
+@@ -86,3 +86,3 @@ static uint64_t root;
+ /* Send debug messages to syslog if != 0. */
+-int debug;
++static int debug;
+