summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/sic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/sic')
-rw-r--r--net-irc/sic/Manifest2
-rw-r--r--net-irc/sic/metadata.xml5
-rw-r--r--net-irc/sic/sic-1.1.ebuild33
-rw-r--r--net-irc/sic/sic-1.2.ebuild36
4 files changed, 76 insertions, 0 deletions
diff --git a/net-irc/sic/Manifest b/net-irc/sic/Manifest
new file mode 100644
index 000000000000..a8907531bdd5
--- /dev/null
+++ b/net-irc/sic/Manifest
@@ -0,0 +1,2 @@
+DIST sic-1.1.tar.gz 5061 SHA256 f24d63c7ae5f3715f3c3885f5bd07d45ffa1b0af830a25523baec94653484dc2 SHA512 6cb4f609ec57f9ccc21ec2502eee27abed3b51000ffbd55a7c9ca25fb8d67526b193c5c0d5f155e207b4ce20487fb7bd8f392a9d802cb143abe3aac58c73f84e WHIRLPOOL f2b1a23fb443f2adb1f357ec0bb58c9054366dff2e2f7da965311d98078b37cb0db9c1e9c013ec482df9b01812645f4de91bf62c82b0ed23d0c4c7b36eb0e88d
+DIST sic-1.2.tar.gz 4563 SHA256 ac07f905995e13ba2c43912d7a035fbbe78a628d7ba1c256f4ca1372fb565185 SHA512 5659ed9d8a5986dda90dbe1155c27a5fd0ab4b1fcad2c1a20997c530bf03864e6c08bdeffc025c728629ab11872af6a1250761160b91f148dc37d77a49046dc9 WHIRLPOOL 1fa1dd4caeff1122b954b1a54f131e2268cb805907746e5fad54467c6510d3e103c0e44b3f1716a4d7c27dae763580bbc95141c84011bd52d5b7a26be64a1268
diff --git a/net-irc/sic/metadata.xml b/net-irc/sic/metadata.xml
new file mode 100644
index 000000000000..6ef15e900f17
--- /dev/null
+++ b/net-irc/sic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+</pkgmetadata>
diff --git a/net-irc/sic/sic-1.1.ebuild b/net-irc/sic/sic-1.1.ebuild
new file mode 100644
index 000000000000..7cfe093ba549
--- /dev/null
+++ b/net-irc/sic/sic-1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="An extremly simple IRC client"
+HOMEPAGE="http://tools.suckless.org/sic"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS +=/g" \
+ -e "s/-Os//" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ -e "s/-s //g" \
+ -e "s/= cc/= $(tc-getCC)/g" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}
diff --git a/net-irc/sic/sic-1.2.ebuild b/net-irc/sic/sic-1.2.ebuild
new file mode 100644
index 000000000000..d7e44877c334
--- /dev/null
+++ b/net-irc/sic/sic-1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="An extremly simple IRC client"
+HOMEPAGE="http://tools.suckless.org/sic"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS =/CFLAGS +=/g" \
+ -e "s/-Os//" \
+ -e "s/LDFLAGS = -s/LDFLAGS +=/" \
+ -e "/^LIBS =/d" \
+ -e "s/= cc/= $(tc-getCC)/g" \
+ config.mk || die "sed failed"
+
+ # enable verbose build
+ sed -i 's/@${CC}/${CC}/' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}