summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-07-31 12:55:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-07-31 13:29:15 +0200
commit74bdd937197f05e493a84f0c9c392acad6d15960 (patch)
tree723b71625b6038e5b577973b5fb644cdbfe73c11 /net-libs
parentkde-apps/ark: Disable continuously broken plugins-clirartest (diff)
downloadgentoo-74bdd937197f05e493a84f0c9c392acad6d15960.tar.gz
gentoo-74bdd937197f05e493a84f0c9c392acad6d15960.tar.bz2
gentoo-74bdd937197f05e493a84f0c9c392acad6d15960.zip
net-libs/libquotient: add 0.8.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/files/libquotient-0.8.0-no-android.patch29
-rw-r--r--net-libs/libquotient/files/libquotient-0.8.0-no-tests.patch34
-rw-r--r--net-libs/libquotient/libquotient-0.8.0.ebuild62
4 files changed, 126 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index 104a45f5ed72..0c92d936edf6 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1 +1,2 @@
DIST libquotient-0.7.2.tar.gz 671676 BLAKE2B 37a22c01b94bb77b89534e48ebcf8427429760095ecdc9427297c57e1d7dabdaaeaf9c7498b4695d23e468b89e1ac9cd44b9f64593454e5c3f8f452b95745c75 SHA512 ba849b938c0bf93e075da466a8360703fb903ac2735b35a7e83944a1288c9324ff76daaf57164144c55cef450fc658e42e6dcacfd23f87a4db455019e9c21f47
+DIST libquotient-0.8.0.tar.gz 725645 BLAKE2B f8374e31755f73957bef5ec960e04e131bddaba8f05b43cb369dd2dda62021f22ab1e7c640f73c874db83b580a5ef789df1c5cf4590d8395d2aaaa5fdce7c506 SHA512 5ea12d8c1e0091a0dd1a6130b9ca540f993ad560acbe6391522eacae6c38ef83665338bb407d0898d03bac5e0660b46db2f735b9ded35ff4b195a8d34c8c96ff
diff --git a/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch b/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch
new file mode 100644
index 000000000000..5b2e34123226
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.8.0-no-android.patch
@@ -0,0 +1,29 @@
+From ad928b9f34f5e6f42c8555a0a502c35de6cb86b5 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 3 Jan 2021 15:18:01 +0100
+Subject: [PATCH 1/2] Install EXPORT_ANDROID_MK only if(ANDROID)
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0a32ee4e..7e03085f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -387,7 +387,10 @@ install(FILES
+ "${CMAKE_CURRENT_BINARY_DIR}/${QUOTIENT_LIB_NAME}/${QUOTIENT_LIB_NAME}ConfigVersion.cmake"
+ DESTINATION ${CMakeFilesLocation}
+ )
+-install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++
++if (ANDROID)
++ install(EXPORT_ANDROID_MK ${QUOTIENT_LIB_NAME}Targets DESTINATION ${CMAKE_INSTALL_DATADIR}/ndk-modules)
++endif ()
+
+ if (WIN32)
+ install(FILES mime/packages/freedesktop.org.xml DESTINATION mime/packages)
+--
+2.41.0
+
diff --git a/net-libs/libquotient/files/libquotient-0.8.0-no-tests.patch b/net-libs/libquotient/files/libquotient-0.8.0-no-tests.patch
new file mode 100644
index 000000000000..96fe1029c826
--- /dev/null
+++ b/net-libs/libquotient/files/libquotient-0.8.0-no-tests.patch
@@ -0,0 +1,34 @@
+From c35f062d1c9975ec0bdfdcbcdeb6b9973b73f86b Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 24 Dec 2022 22:51:12 +0100
+Subject: [PATCH 2/2] Put Qt5Test dependency behind -DBUILD_TESTING
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7e03085f..f2ab0ae7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -92,7 +92,7 @@ else()
+ set(QtExtraModules "Multimedia") # See #483
+ endif()
+ string(REGEX REPLACE "^(.).*" "Qt\\1" Qt ${QtMinVersion}) # makes "Qt5" or "Qt6"
+-find_package(${Qt} ${QtMinVersion} REQUIRED Core Network Gui Test ${QtExtraModules})
++find_package(${Qt} ${QtMinVersion} REQUIRED Core Network Gui ${QtExtraModules})
+ get_filename_component(Qt_Prefix "${${Qt}_DIR}/../../../.." ABSOLUTE)
+
+ find_package(${Qt}Keychain REQUIRED)
+@@ -344,6 +344,7 @@ configure_file(${PROJECT_NAME}.pc.in ${CMAKE_CURRENT_BINARY_DIR}/${QUOTIENT_LIB_
+ # Configure testing
+
+ if (BUILD_TESTING)
++ find_package(${Qt}Test ${QtMinVersion} REQUIRED)
+ enable_testing()
+ add_subdirectory(quotest)
+ add_subdirectory(autotests)
+--
+2.41.0
+
diff --git a/net-libs/libquotient/libquotient-0.8.0.ebuild b/net-libs/libquotient/libquotient-0.8.0.ebuild
new file mode 100644
index 000000000000..028bf333bf11
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/olm
+ dev-libs/openssl:=
+ dev-libs/qtkeychain:=[qt5(+)]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-qt/qtconcurrent:5
+ dev-qt/qttest:5
+ )
+"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.8.0-no-android.patch
+ "${FILESDIR}"/${PN}-0.8.0-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TESTING=$(usex test)
+ -DQuotient_ENABLE_E2EE=ON
+ )
+ use test && mycmakeargs+=(
+ -DQuotient_INSTALL_TESTS=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # https://github.com/quotient-im/libQuotient/issues/435
+ # testolmaccount requires network connection/server set up
+ local myctestargs=(
+ -j1
+ -E "(testolmaccount)"
+ )
+ cmake_src_test
+}