summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-09-21 15:36:49 -0400
committerTim Harder <radhermit@gentoo.org>2016-09-21 16:25:27 -0400
commit38237317ba2e7b285b4f669d8ab62076d89485fa (patch)
tree95b330bf3831a98480e7c138817ff994d6b28640 /net-mail/offlineimap
parentwww-client/firefox: add 'jemalloc' flag to metadata.xml (diff)
downloadgentoo-38237317ba2e7b285b4f669d8ab62076d89485fa.tar.gz
gentoo-38237317ba2e7b285b4f669d8ab62076d89485fa.tar.bz2
gentoo-38237317ba2e7b285b4f669d8ab62076d89485fa.zip
net-mail/offlineimap: version bump to 7.0.7
Diffstat (limited to 'net-mail/offlineimap')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.0.7.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index a337889a52df..7f817a2d81db 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -1,3 +1,4 @@
DIST offlineimap-6.5.6.tar.gz 187801 SHA256 650fa588bdf86624575a5196fa12e9059b74673a51593718d058365230189abd SHA512 3f7cb63d00486de2d648aa9dd3637ce252dd100bc8237742d11f749726b2b14907c07c802ba0fd5891c88f5062f9a2d05ebc78ceee8c30981f4c4579c3143d6e WHIRLPOOL 0ca66a196683555c5a9e193ccb0a84a8104b2a7715a3839f364d77d1376637a4938b39fa7e9a47f925cde2516a4b0ace94d9e4f9d62dcff50501510c834cb023
DIST offlineimap-6.7.0.3.tar.gz 679221 SHA256 0b7cd43501d1a65fb5e7e4f3a5d0a61f61435ec6b3a7385cc146e924eb6b03ed SHA512 21800eb14e814fa04b983e9718a5780deda4c99ae55ef900ccec9f1e65f9bb783c3469e00e6595c7dfddb60d760a6b3c98ae979da3219de51c8ae107ff1c077a WHIRLPOOL d8983260f309f427abcab65bc539bf8ff7ab38168643a863cc3d7e10a85dc864e4a6a11511a1cba32d2eb74833714f9b3f499b7d14d28800174c58816d59608c
DIST offlineimap-7.0.6.tar.gz 690372 SHA256 f50002d0760794f1190526b74e2010becc16d2ff541526aadc95ec11cb064fd7 SHA512 9a1ff0abecb8d0b6cbedf4c7fad9f40de403ac789bb8bcfdea1dcacc1c36769643348ffe095d5e0b044f9ea17378512856a285c079c1713074432cc9f8ffeb27 WHIRLPOOL 596981227579162da62029c0a9ed4cda49ee35e8bc1ab6d1773f9933808c9909ef92c462e1f83f28deee2926dbc5641b417040281180921fe196fea53fd60c3b
+DIST offlineimap-7.0.7.tar.gz 691104 SHA256 802e7574fd4771c4e3bf5da11cb039e58c11bbbe799776bd9d05aa0eb8ed299c SHA512 32b28846ab6acf4a0184660039d808a07c78557c4205efc1cd30ff993f7fc3cc0855a3aafb0dd1f98bbfd2acdc8ee63a56cd28e182567ce9b85341cd17211881 WHIRLPOOL 47c77ebe12b9f3b64ea220218e3f4ce61ed447aba8916ae4ce19304a2e265ddb363ddbeb83fce54a94b7bd42f2d03246d956830b7c9d91923a9edd481b2ad5b0
diff --git a/net-mail/offlineimap/offlineimap-7.0.7.ebuild b/net-mail/offlineimap/offlineimap-7.0.7.ebuild
new file mode 100644
index 000000000000..2915dc79919a
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.0.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}