summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-11-09 23:22:05 -0500
committerTim Harder <radhermit@gentoo.org>2016-11-09 23:22:30 -0500
commitba859a2d08850f46c5cfb482d1a6f6a498b1b989 (patch)
treeb0ff18a0b95ee9625fc2f36c1090a218ca377a18 /net-mail/offlineimap
parentxfce-extra/xfce4-notifyd: Bump to 0.3.4 (diff)
downloadgentoo-ba859a2d08850f46c5cfb482d1a6f6a498b1b989.tar.gz
gentoo-ba859a2d08850f46c5cfb482d1a6f6a498b1b989.tar.bz2
gentoo-ba859a2d08850f46c5cfb482d1a6f6a498b1b989.zip
net-mail/offlineimap: version bump to 7.0.9
Diffstat (limited to 'net-mail/offlineimap')
-rw-r--r--net-mail/offlineimap/Manifest1
-rw-r--r--net-mail/offlineimap/offlineimap-7.0.9.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/net-mail/offlineimap/Manifest b/net-mail/offlineimap/Manifest
index 858142a11926..29f5b8e32071 100644
--- a/net-mail/offlineimap/Manifest
+++ b/net-mail/offlineimap/Manifest
@@ -3,3 +3,4 @@ DIST offlineimap-6.7.0.3.tar.gz 679221 SHA256 0b7cd43501d1a65fb5e7e4f3a5d0a61f61
DIST offlineimap-7.0.6.tar.gz 690372 SHA256 f50002d0760794f1190526b74e2010becc16d2ff541526aadc95ec11cb064fd7 SHA512 9a1ff0abecb8d0b6cbedf4c7fad9f40de403ac789bb8bcfdea1dcacc1c36769643348ffe095d5e0b044f9ea17378512856a285c079c1713074432cc9f8ffeb27 WHIRLPOOL 596981227579162da62029c0a9ed4cda49ee35e8bc1ab6d1773f9933808c9909ef92c462e1f83f28deee2926dbc5641b417040281180921fe196fea53fd60c3b
DIST offlineimap-7.0.7.tar.gz 691104 SHA256 802e7574fd4771c4e3bf5da11cb039e58c11bbbe799776bd9d05aa0eb8ed299c SHA512 32b28846ab6acf4a0184660039d808a07c78557c4205efc1cd30ff993f7fc3cc0855a3aafb0dd1f98bbfd2acdc8ee63a56cd28e182567ce9b85341cd17211881 WHIRLPOOL 47c77ebe12b9f3b64ea220218e3f4ce61ed447aba8916ae4ce19304a2e265ddb363ddbeb83fce54a94b7bd42f2d03246d956830b7c9d91923a9edd481b2ad5b0
DIST offlineimap-7.0.8.tar.gz 691624 SHA256 19da773c1486d3d06ebe04e499f48e57d4224149582672a74876b1f15481bd6a SHA512 6f0dcdaad46e59ba097f9dc4346f8f8ec604d1c4d05e43c15f4dc911eda1425453e8a481fbe92fd87b507da1f7c7b6c9b4f16dc42bb75c0ba6353538efce5514 WHIRLPOOL 1f1e173f23937a14d53bc404c4a18a89670af01f522962beb887d30a863aebbd83a9550a75c9060465536d52e4725348e1fa14ae09c891062fbfe5c893e8b121
+DIST offlineimap-7.0.9.tar.gz 692604 SHA256 aec349b97fe41681ebad48d03cac62dc84e405ad136ac92067ecfcd640bf6a12 SHA512 5b0f505aaf97597fda6e0151df90c986043a6b0b6aad4e38a7a74463596d754cd6095c1c015a140a68c425f207599d8261a6745d92080a959cea8611462ad801 WHIRLPOOL 614bff893bcabff78baf9df9c30295940afee3e3e6f8d878f621d6703ebe1eb546ded268b390fb08ed270474ee97170495c64e2e2cb12e760f8167a5c9d56482
diff --git a/net-mail/offlineimap/offlineimap-7.0.9.ebuild b/net-mail/offlineimap/offlineimap-7.0.9.ebuild
new file mode 100644
index 000000000000..2915dc79919a
--- /dev/null
+++ b/net-mail/offlineimap/offlineimap-7.0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Normally you need only one version of this.
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_REQ_USE="threads,sqlite,ssl?"
+
+inherit distutils-r1
+
+DESCRIPTION="Powerful IMAP/Maildir synchronization and reader support"
+HOMEPAGE="http://offlineimap.org"
+SRC_URI="https://github.com/OfflineIMAP/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc ssl"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="doc? ( app-text/asciidoc )"
+
+# see http://pogma.com/2009/09/09/snow-leopard-and-offlineimap/ and bug 284925
+PATCHES=(
+ "${FILESDIR}/${PN}-7.0.3-darwin10.patch"
+)
+
+src_compile() {
+ distutils-r1_src_compile
+ use doc && emake -C docs man
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc offlineimap.conf offlineimap.conf.minimal
+ use doc && doman docs/{offlineimap.1,offlineimapui.7}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "You will need to configure offlineimap by creating ~/.offlineimaprc"
+ elog "Sample configurations are in /usr/share/doc/${PF}/"
+ elog ""
+ elog "If you connect via ssl/tls and don't use CA cert checking, it will"
+ elog "display the server's cert fingerprint and require you to add it to the"
+ elog "configuration file to be sure it connects to the same server every"
+ elog "time. This serves to help fixing CVE-2010-4532 (offlineimap doesn't"
+ elog "check SSL server certificate) in cases where you have no CA cert."
+ fi
+}