summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2016-08-17 13:13:16 +0800
committerYixun Lan <dlan@gentoo.org>2016-08-17 14:36:25 +0800
commitdd016ae078f9dd434ea83da71d2425490b5824f4 (patch)
tree1904eb2af734ac35413a5af02cebc32fcfdacec2 /net-misc/spice-gtk
parentapp-emulation/spice: live ebuilds updated (diff)
downloadgentoo-dd016ae078f9dd434ea83da71d2425490b5824f4.tar.gz
gentoo-dd016ae078f9dd434ea83da71d2425490b5824f4.tar.bz2
gentoo-dd016ae078f9dd434ea83da71d2425490b5824f4.zip
net-misc/spice-gtk: fine tune IUSEs
1) replace IUSE=gstreamer with IUSE="gstaudio gstvideo" so we can control audio/video backend seperately possible has the combination USE="gstvideo -gstaudio pulseaudio" 2) introduce gentoo.readme to suggest users install mjpeg,vpx,x264 gstreamer plugins Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/files/README.gentoo14
-rw-r--r--net-misc/spice-gtk/metadata.xml2
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild137
3 files changed, 153 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/files/README.gentoo b/net-misc/spice-gtk/files/README.gentoo
new file mode 100644
index 000000000000..e18b6d8e539e
--- /dev/null
+++ b/net-misc/spice-gtk/files/README.gentoo
@@ -0,0 +1,14 @@
+
+If you choose to enable the video streaming support of gstreamer,
+please try to install addtional gst-plugins which matching the video codecs
+
+One the client side:
+ mjpeg,x264 media-plugins/gst-plugins-libav:1.0
+ vpx media-plugins/gst-plugins-vpx:1.0
+
+One the server side (which app-emulation/qemu running), you should also install
+additional gstreamer plugins for the app-emulation/spice package:
+ mjpeg media-plugins/gst-plugins-libav:1.0
+ vpx media-plugins/gst-plugins-vpx:1.0
+ x264 media-plugins/gst-plugins-x264:1.0
+
diff --git a/net-misc/spice-gtk/metadata.xml b/net-misc/spice-gtk/metadata.xml
index 83884db317a4..a84b4fbfe9ac 100644
--- a/net-misc/spice-gtk/metadata.xml
+++ b/net-misc/spice-gtk/metadata.xml
@@ -19,5 +19,7 @@
<flag name="mjpeg">Enable builtin mjpeg video decoder</flag>
<flag name="webdav">Support for folder-sharing between guest and client
using <pkg>net-libs/phodav</pkg></flag>
+ <flag name="gstaudio">Using gstreamer backend as audio decodec support</flag>
+ <flag name="gstvideo">Using gstreamer backend as video decodec support</flag>
</use>
</pkgmetadata>
diff --git a/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild b/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
new file mode 100644
index 000000000000..33d4a5b829ed
--- /dev/null
+++ b/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+WANT_AUTOMAKE="1.12"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools eutils vala readme.gentoo-r1
+
+DESCRIPTION="Set of GObject and Gtk objects for connecting to Spice servers and a client GUI"
+HOMEPAGE="http://spice-space.org https://cgit.freedesktop.org/spice/spice-gtk/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+SRC_URI="http://spice-space.org/download/gtk/${P}.tar.bz2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus gstaudio gstvideo gtk3 +introspection lz4 mjpeg policykit pulseaudio sasl smartcard static-libs usbredir vala webdav libressl"
+
+REQUIRED_USE="?? ( pulseaudio gstaudio )"
+
+# TODO:
+# * check if sys-freebsd/freebsd-lib (from virtual/acl) provides acl/libacl.h
+# * use external pnp.ids as soon as that means not pulling in gnome-desktop
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ pulseaudio? ( media-sound/pulseaudio[glib] )
+ gstvideo? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ )
+ gstaudio? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ media-libs/gst-plugins-good:1.0
+ )
+ >=x11-libs/pixman-0.17.7
+ >=media-libs/celt-0.5.1.1:0.5.1
+ media-libs/opus
+ gtk3? ( x11-libs/gtk+:3[introspection?] )
+ >=dev-libs/glib-2.36:2
+ >=x11-libs/cairo-1.2
+ virtual/jpeg:0=
+ sys-libs/zlib
+ introspection? ( dev-libs/gobject-introspection )
+ lz4? ( app-arch/lz4 )
+ sasl? ( dev-libs/cyrus-sasl )
+ smartcard? ( app-emulation/qemu[smartcard] )
+ usbredir? (
+ sys-apps/hwids
+ >=sys-apps/usbredir-0.4.2
+ virtual/libusb:1
+ virtual/libgudev:=
+ policykit? (
+ sys-apps/acl
+ >=sys-auth/polkit-0.110-r1
+ !~sys-auth/polkit-0.111 )
+ )
+ webdav? (
+ net-libs/phodav:2.0
+ >=dev-libs/glib-2.43.90:2
+ >=net-libs/libsoup-2.49.91 )
+"
+DEPEND="${RDEPEND}
+ >=app-emulation/spice-protocol-0.12.11
+ dev-perl/Text-CSV
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+# Hard-deps while building from git:
+# dev-lang/vala:0.14
+# dev-lang/perl
+
+# Prevent sandbox violations, bug #581836
+# https://bugzilla.gnome.org/show_bug.cgi?id=581836
+addpredict /dev
+
+src_prepare() {
+ epatch_user
+
+ AT_NO_RECURSIVE="yes" eautoreconf
+
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use vala ; then
+ # force vala regen for MinGW, etc
+ rm -fv gtk/controller/controller.{c,vala.stamp} gtk/controller/menu.c
+ fi
+
+ myconf="
+ --disable-maintainer-mode \
+ $(use_enable static-libs static) \
+ $(use_enable introspection) \
+ $(use_with sasl) \
+ $(use_enable smartcard) \
+ $(use_enable usbredir) \
+ $(use_with usbredir usb-ids-path /usr/share/misc/usb.ids) \
+ $(use_with usbredir usb-acl-helper-dir /usr/libexec) \
+ $(use_with gtk3 gtk 3.0) \
+ $(use_enable policykit polkit) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable gstaudio) \
+ $(use_enable gstvideo) \
+ $(use_enable mjpeg builtin-mjpeg) \
+ $(use_enable vala) \
+ $(use_enable webdav) \
+ $(use_enable dbus) \
+ --disable-gtk-doc \
+ --disable-werror \
+ --enable-pie"
+
+ econf ${myconf}
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ # Remove .la files if they're not needed
+ use static-libs || prune_libtool_files
+
+ make_desktop_entry spicy Spicy "utilities-terminal" "Network;RemoteAccess;"
+ readme.gentoo_create_doc
+}