summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-17 21:09:42 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-17 21:11:15 +0100
commit658a8bcae747c877dc617695574d6c9572d05260 (patch)
treedeec58cfff92be537fdaf4607ad002ad9d5cd36d /net-misc/youtube-dl
parentpackage.mask: Last rite net-nntp/hellanzb, #449716 (diff)
downloadgentoo-658a8bcae747c877dc617695574d6c9572d05260.tar.gz
gentoo-658a8bcae747c877dc617695574d6c9572d05260.tar.bz2
gentoo-658a8bcae747c877dc617695574d6c9572d05260.zip
net-misc/youtube-dl: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-misc/youtube-dl')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2017.02.17.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index 367364e6e88f..fbafe626643e 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.12.22.tar.gz 2502964 SHA256 f5bc5eb1af17391b7a1da795f4181c3702fb2c1da2668b25f1260dbdba882524 SHA512 87fee134da660a4feb4cfcd2cbb35cb9682e6ed08c766e3c89f6c986f991cac78c64f5bf8a1d15c4080e4df0909c6a360137407a7896b93f8f41cf4493f341cb WHIRLPOOL 6909d34958e4152be3334723c68d207bb34db2996d90908829ebd3ee45d28768d7f6cba8ce0fb19de440b34fb96b46b3d5b8bf830c998037c4f4d59e574206c3
DIST youtube-dl-2017.02.07.tar.gz 2567271 SHA256 e35415388815250e4d32055929850c8d6de0c1b4781b1f70eb80fda0b01a38bf SHA512 075417ba59660915db58a1a8a03a4212ebab73ddbf935d44b82482078d97d530770871ef7be7c7b10e01c2800c279642c988d19a7d546661422900aafe2c97a7 WHIRLPOOL afd425501294fc00241474d8ca540f1c0be87c7da9d4a02cc1bae6e66e08a79864aaf622c2d2be996259018f0be393b2070f25d4e4a430dea469193491b371ca
DIST youtube-dl-2017.02.14.tar.gz 2581332 SHA256 7fde29844c1980416f91d6152a580611b55eeaf815ecda41e93c63ed658f9ae1 SHA512 6df79f304fa24f889629dd4cc4a24c90af8e1c9fb1352c5b1d3a5685f91b81fff9a71c5be31decc85515b93f7153607096ef9f47148364a2d562922c52f79a09 WHIRLPOOL 8433dccb6f18a9ad72a63de77e43c428bc89c0023969105ea002f0e05beae260e3279e2344ce5261586d907e01004deb4e391c13d2eaaabff4b841762bbd04bb
+DIST youtube-dl-2017.02.17.tar.gz 2583825 SHA256 4b1c3f05fb816e9d02dc3f0188e16200031cc0bc4fd40df904ee0806f478601a SHA512 fb19e2f3789f9b5efe9da16b11abf47083bafe4aee6732f2ee707af6e2461624942506170831653dcae87c0d7ed78da78884a24c287c76be3ff947dee06e46ac WHIRLPOOL 2f60683e8d7c437c8756bf976fb9d3d0a6b4e25f7a9c987f63ab4c68083cd6bea41fd5daa9f54eeb214af133cd3b22e8b7bf9ecb38474396ac4e43b6a26e7b64
diff --git a/net-misc/youtube-dl/youtube-dl-2017.02.17.ebuild b/net-misc/youtube-dl/youtube-dl-2017.02.17.ebuild
new file mode 100644
index 000000000000..67313dfefaa3
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2017.02.17.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5})
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="+offensive test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+python_prepare_all() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 porncom pornhd pornotube pornovoisines pornoxo
+ ruleporn sexu slutload spankbang spankwire sunporno thisav tube8
+ vporn watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz
+ youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ drtuber pornhub redtube xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+python_test() {
+ emake test
+}
+
+python_install_all() {
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+}