summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-18 19:32:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-18 19:36:22 +0100
commit6610dcce6753bb78526d1c159f8010e64aa70e4d (patch)
tree8e7f7781e50c8c33a7c67c8e6b864eb0164efdf3 /net-p2p
parentsys-devel/autoconf-archive: Removed old. (diff)
downloadgentoo-6610dcce6753bb78526d1c159f8010e64aa70e4d.tar.gz
gentoo-6610dcce6753bb78526d1c159f8010e64aa70e4d.tar.bz2
gentoo-6610dcce6753bb78526d1c159f8010e64aa70e4d.zip
net-p2p/ktorrent: Fix build with Qt 5.11
Bug: https://bugs.gentoo.org/650808 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/files/ktorrent-5.1.0-qt-5.11.patch53
-rw-r--r--net-p2p/ktorrent/ktorrent-5.1.0.ebuild4
2 files changed, 56 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/files/ktorrent-5.1.0-qt-5.11.patch b/net-p2p/ktorrent/files/ktorrent-5.1.0-qt-5.11.patch
new file mode 100644
index 000000000000..f59e074134c8
--- /dev/null
+++ b/net-p2p/ktorrent/files/ktorrent-5.1.0-qt-5.11.patch
@@ -0,0 +1,53 @@
+From 4befccc3d0ebbd9235e6f10d411f139802e3871a Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 18 Mar 2018 19:13:26 +0100
+Subject: [PATCH] Fix build with Qt 5.11 (missing headers)
+
+Reviewers: stikonas
+
+Differential Revision: https://phabricator.kde.org/D11456
+---
+ ktorrent/dialogs/fileselectdlg.cpp | 1 +
+ ktorrent/groups/groupview.cpp | 1 +
+ plugins/search/searchprefpage.cpp | 1 +
+ 3 files changed, 3 insertions(+)
+
+diff --git a/ktorrent/dialogs/fileselectdlg.cpp b/ktorrent/dialogs/fileselectdlg.cpp
+index 139b4752..ec7d8ede 100644
+--- a/ktorrent/dialogs/fileselectdlg.cpp
++++ b/ktorrent/dialogs/fileselectdlg.cpp
+@@ -20,6 +20,7 @@
+
+ #include "fileselectdlg.h"
+
++#include <QButtonGroup>
+ #include <QMenu>
+ #include <QPushButton>
+ #include <QTextCodec>
+diff --git a/ktorrent/groups/groupview.cpp b/ktorrent/groups/groupview.cpp
+index 990ed0d3..76208144 100644
+--- a/ktorrent/groups/groupview.cpp
++++ b/ktorrent/groups/groupview.cpp
+@@ -23,6 +23,7 @@
+ #include <QAction>
+ #include <QDragEnterEvent>
+ #include <QDropEvent>
++#include <QHeaderView>
+ #include <QInputDialog>
+ #include <QMenu>
+ #include <QTreeWidgetItemIterator>
+diff --git a/plugins/search/searchprefpage.cpp b/plugins/search/searchprefpage.cpp
+index 667e7a82..4be6cd5c 100644
+--- a/plugins/search/searchprefpage.cpp
++++ b/plugins/search/searchprefpage.cpp
+@@ -21,6 +21,7 @@
+
+ #include "searchprefpage.h"
+
++#include <QButtonGroup>
+ #include <QCheckBox>
+ #include <QFile>
+ #include <QInputDialog>
+--
+2.16.2
+
diff --git a/net-p2p/ktorrent/ktorrent-5.1.0.ebuild b/net-p2p/ktorrent/ktorrent-5.1.0.ebuild
index ee8be9828980..ef67d30802dc 100644
--- a/net-p2p/ktorrent/ktorrent-5.1.0.ebuild
+++ b/net-p2p/ktorrent/ktorrent-5.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -78,6 +78,8 @@ RDEPEND="${COMMON_DEPEND}
!net-p2p/ktorrent:4
"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
src_configure() {
local mycmakeargs=(
-DENABLE_BWSCHEDULER_PLUGIN=$(usex bwscheduler)