summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Pronin <dannftk@yandex.ru>2024-02-19 15:48:00 +0300
committerSam James <sam@gentoo.org>2024-03-21 02:55:35 +0000
commitf133f16b27b7e3036eb844ea3842ab6784c50797 (patch)
treeafb85cad1c749e59ddd233eadb2f086eb416b358 /net-print
parentdev-util/ebuildtester: correct sphinx dependency (diff)
downloadgentoo-f133f16b27b7e3036eb844ea3842ab6784c50797.tar.gz
gentoo-f133f16b27b7e3036eb844ea3842ab6784c50797.tar.bz2
gentoo-f133f16b27b7e3036eb844ea3842ab6784c50797.zip
net-print/libcupsfilters: add a patch to fix building with c++17
c++17 does not support dynamic exception specification any longer Signed-off-by: Denis Pronin <dannftk@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/35425 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-print')
-rw-r--r--net-print/libcupsfilters/files/libcupsfilters-2.0.0-r3-c++17.patch14
-rw-r--r--net-print/libcupsfilters/libcupsfilters-2.0.0-r3.ebuild4
2 files changed, 18 insertions, 0 deletions
diff --git a/net-print/libcupsfilters/files/libcupsfilters-2.0.0-r3-c++17.patch b/net-print/libcupsfilters/files/libcupsfilters-2.0.0-r3-c++17.patch
new file mode 100644
index 000000000000..8051718df9f5
--- /dev/null
+++ b/net-print/libcupsfilters/files/libcupsfilters-2.0.0-r3-c++17.patch
@@ -0,0 +1,14 @@
+--- a/cupsfilters/pdftoraster.cxx
++++ b/cupsfilters/pdftoraster.cxx
+@@ -2198,7 +2198,11 @@
+ // For compatibility with g++ >= 4.7 compilers _GLIBCXX_THROW
+ // should be used as a guard, otherwise use traditional definition
+ #ifndef _GLIBCXX_THROW
++#if __cplusplus < 201703L
+ #define _GLIBCXX_THROW throw
++#else
++#define _GLIBCXX_THROW(...) noexcept(false)
++#endif
+ #endif
+
+ void * operator new(size_t size) _GLIBCXX_THROW (std::bad_alloc)
diff --git a/net-print/libcupsfilters/libcupsfilters-2.0.0-r3.ebuild b/net-print/libcupsfilters/libcupsfilters-2.0.0-r3.ebuild
index af4e7ce42ad6..6a44a004e2a7 100644
--- a/net-print/libcupsfilters/libcupsfilters-2.0.0-r3.ebuild
+++ b/net-print/libcupsfilters/libcupsfilters-2.0.0-r3.ebuild
@@ -39,6 +39,10 @@ BDEPEND="
test? ( media-fonts/dejavu )
"
+PATCHES=(
+ "${FILESDIR}/${P}-r3-c++17.patch"
+)
+
src_prepare() {
default