summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-09-20 07:01:51 -0500
committerBen Kohler <bkohler@gentoo.org>2022-09-20 07:03:00 -0500
commit0aaa953b3e08b8d320e85c417faf9110bd4a120f (patch)
tree1334def5f60b5b996f7df956c443d86edf97e99d /net-proxy/tinyproxy
parentsys-kernel/vanilla-sources: add 5.4.214, drop 5.4.213 (diff)
downloadgentoo-0aaa953b3e08b8d320e85c417faf9110bd4a120f.tar.gz
gentoo-0aaa953b3e08b8d320e85c417faf9110bd4a120f.tar.bz2
gentoo-0aaa953b3e08b8d320e85c417faf9110bd4a120f.zip
net-proxy/tinyproxy: add 1.11.1_p20220908
https://bugs.gentoo.org/871924 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-proxy/tinyproxy')
-rw-r--r--net-proxy/tinyproxy/Manifest1
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.11.1_p20220908.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/net-proxy/tinyproxy/Manifest b/net-proxy/tinyproxy/Manifest
index 631360fede1a..c837f2fdb7be 100644
--- a/net-proxy/tinyproxy/Manifest
+++ b/net-proxy/tinyproxy/Manifest
@@ -1 +1,2 @@
DIST tinyproxy-1.11.1.tar.xz 182080 BLAKE2B d39fa1986343af60cdfd07c6a049962e646a72874f7058fd082b9758bae3c7bc1a2288103527e0e1054ab098a3a41fc67eb3e08cd160e2bd4bd030e114326a6f SHA512 2e3435bbfece3797c11ccce222eef494ed92e00dd82bea2c40a54e454b7e03c8abc8e09b244f2da7192209c39047369439d08974b79eebc996fb3095230d0374
+DIST tinyproxy-1.11.1_p20220908.tar.gz 112898 BLAKE2B 0f00a103661a5e5891a9f82cb95f1a421a47e68ea6e2144ead01241e6b4bcda8dbd4dce302432fa0432aae1e048b4a788a0ad3bad2dc8691906b872730c31b2b SHA512 3d1c0ad4915e81e775e981b8ba625664128c8d63b2093cc29b3873dc83da4e16646e2a39e32769f463bab1d5af2b699deaa546a705f1269d5a6dfc2c927dafef
diff --git a/net-proxy/tinyproxy/tinyproxy-1.11.1_p20220908.ebuild b/net-proxy/tinyproxy/tinyproxy-1.11.1_p20220908.ebuild
new file mode 100644
index 000000000000..98a6c6810fd4
--- /dev/null
+++ b/net-proxy/tinyproxy/tinyproxy-1.11.1_p20220908.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd tmpfiles
+
+COMMIT=3764b8551463b900b5b4e3ec0cd9bb9182191cb7
+
+DESCRIPTION="A lightweight HTTP/SSL proxy"
+HOMEPAGE="https://github.com/tinyproxy/tinyproxy/"
+SRC_URI="https://github.com/tinyproxy/tinyproxy/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="test debug +filter-proxy reverse-proxy transparent-proxy
++upstream-proxy +xtinyproxy-header"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( xtinyproxy-header )"
+
+S="${WORKDIR}"/${PN}-${COMMIT}
+
+DEPEND="
+ acct-group/tinyproxy
+ acct-user/tinyproxy
+"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s|nobody|${PN}|g" \
+ etc/${PN}.conf.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable filter-proxy filter) \
+ $(use_enable reverse-proxy reverse) \
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable upstream-proxy upstream) \
+ $(use_enable xtinyproxy-header xtinyproxy) \
+ --localstatedir=/var
+}
+
+src_test() {
+ # The make check target does not run the test suite
+ emake test
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ diropts -m0775 -o ${PN} -g ${PN}
+ keepdir /var/log/${PN}
+
+ newinitd "${FILESDIR}"/${PN}-1.10.0.initd tinyproxy
+ systemd_newunit "${FILESDIR}"/${PN}-1.10.0.service tinyproxy.service
+ dotmpfiles "${FILESDIR}"/${PN}.tmpfiles.conf
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog "For filtering domains and URLs, enable filter option in the configuration"
+ elog "file and add them to the filter file (one domain or URL per line)."
+}