summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-06-16 18:16:49 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-11 09:25:59 +0200
commit67055ebbb2c4ef0b23687a3ee0c0769917e23bac (patch)
tree2397e8a0c282ea48c694a7c1c6463ea63950cdaf /sci-chemistry
parentdev-python/pythran: Keyword 0.14.0 riscv, #913788 (diff)
downloadgentoo-67055ebbb2c4ef0b23687a3ee0c0769917e23bac.tar.gz
gentoo-67055ebbb2c4ef0b23687a3ee0c0769917e23bac.tar.bz2
gentoo-67055ebbb2c4ef0b23687a3ee0c0769917e23bac.zip
sci-chemistry/cluster: Fix error: ISO C++17 does not allow register storage class
Closes: https://bugs.gentoo.org/898132 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31488 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild31
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-drop-registers.patch23
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild b/sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild
new file mode 100644
index 000000000000..63f38eed67d2
--- /dev/null
+++ b/sci-chemistry/cluster/cluster-1.3.081231-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Build lists of collections of interacting items"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/index.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${PN}.${PV}.src.tgz"
+S="${WORKDIR}"/${PN}1.3src
+
+LICENSE="richardson"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-ldflags.patch
+ "${FILESDIR}"/${PV}-includes.patch
+ "${FILESDIR}"/${PV}-drop-registers.patch
+)
+
+src_configure() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ newbin ${PN} molprobity-${PN}
+ dodoc README.cluster
+}
diff --git a/sci-chemistry/cluster/files/1.3.081231-drop-registers.patch b/sci-chemistry/cluster/files/1.3.081231-drop-registers.patch
new file mode 100644
index 000000000000..c00922591faa
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-drop-registers.patch
@@ -0,0 +1,23 @@
+Bug: https://bugs.gentoo.org/898132
+--- a/utility.cpp
++++ b/utility.cpp
+@@ -107,8 +107,8 @@ int compArgStr(const char *str, const char *arg, int min) {
+ }
+
+ int parseInteger(const char *str, int start, int len) {
+- register int value = 0;
+- register char ch;
++ int value = 0;
++ char ch;
+ int neg = 0, inside = 0;
+
+ if (!str || start < 0) { return 0; }
+@@ -136,7 +136,7 @@ int parseInteger(const char *str, int start, int len) {
+ double parseReal(const char *str, int start, int len) {
+ double value = 0.0, scale = 1.0, expscale = 1.0, expfact = 10.0;
+ int expval = 0;
+- register char ch;
++ char ch;
+ int inside = 0, infract = 0, inexp = 0, insn = 0, esn = 0;
+
+ if (!str || start < 0) { return 0; }